Bug #693

Camera app crashes when selecting the third (non-video non-photo) mode

Added by Simon Josefsson 10 months ago. Updated 10 months ago.

Status:Rejected Start date:11/08/2013
Priority:Normal Due date:
Assignee:Paul Kocialkowski % Done:

0%

Category:Galaxy S 3 (I9300)
Target version:Replicant 4.0
Resolution:duplicate

Description

Taking pictures and recording video works fine, but when I select the third mode in the camera app, it crashes. I'm attaching three logs. This is reproducible, so if you want me to provide further details, I can.

boot - complete main log after a fresh boot (46 kB) Simon Josefsson, 11/08/2013 09:33 AM

camera-started - complete main log after camera app started (55.9 kB) Simon Josefsson, 11/08/2013 09:33 AM

camera-crashed - complete main log after camera crashed (64.3 kB) Simon Josefsson, 11/08/2013 09:33 AM

History

Updated by Simon Josefsson 10 months ago

The mode is called the panorama mode.

Updated by Paul Kocialkowski 10 months ago

This happens because the returned camera preview format is RGB565 and the panorama mode explicitly requires YUV420. We need RGB565 because our EGL implementation cannot handle color YUV (it would be slower and black & white only preview).

Updated by Paul Kocialkowski 10 months ago

  • Status changed from New to Rejected
  • Resolution set to duplicate

Duplicate of #705

Also available in: Atom PDF