SDK

The ReplicantSDK page holds a list of the released Replicant SDK builds.

Rationale

Replicant provides its own SDK, built from source, since the Android SDK as released by Google is distributed under a non-free license and suggests installing non-free plug-ins such as the Google APIs.
The Replicant SDK contains only free software and will not check for plug-ins or updates from Google.

Installation

After downloading the Replicant SDK from the ReplicantSDK page, it should work the same as the Android SDK as provided by Google except that the Replicant SDK already contains a built and ready to use emulator image.
Please refer to: http://developer.android.com/sdk/installing/index.html for further assistance.

Dependencies

Required Packages

The Replicant SDK requires the following packages:
  • SDL
  • OpenJDK 6
  • Ant

In some unlikely cases, creating a "JAVA_HOME" environment variable and pointing it to your JDK's true install location (not the "bin" directory but one level upward) may prove necessary.

Additional requirements for amd64

Note that the Replicant SDK is built for x86 platforms and you may need compatibility libraries such as ia32-libs.

Command line installation

Trisquel/Ubuntu/Debian

Required packages:

apt-get install libsdl1.2debian openjdk-6-jdk ant

Additional requirements for amd64:

apt-get install ia32-libs

Usage guides

Using Eclipse

You may want to install Eclipse to work on Android Java applications. Note that this is not strictly necessary as all the required tools are already present on the SDK package.

Installing the "Android Development Tools" plugin for Eclipse

The following instructions work with Eclipse 3.7.2 (Indigo) as installed via Apt under Trisquel Toutatis GNU/Linux.

sudo aptitude install eclipse

Once you have Eclipse installed and running properly, you may want to install the Android Development Tools plugin.

  • The Replicant 4 SDK requires ADT version 16. You will need to download it from Google's archives and then manually install it in Eclipse:

http://dl.google.com/android/ADT-16.0.0.zip

  • in Eclipse 3.7

- select "Window" > "Preferences" > "Install/Update" > "Available Software Sites"
- click the "Add" button
- name your software site something recognizable, e.g. "ADT 16.0.0"
- click "Archive" and select the "ADT-16.0.0.zip" file

  • in Eclipse 3.7

- select "Help" > "Install New Software"
- select the "ADT 16.0.0" software site from the dropdown menu
- select the "Developer Tools" software package
- verify that the "Android DDMS" and "Android Development Tools" sub-packages were selected
- click the "Next" to install Android Developer Tools

  • restart Eclipse

Pointing "Android Development Tools" to the SDK directory

When you have installed ADT and restarted Eclipse, select the "Window" menu. You should see a menu entry named "Android SDK and AVD Manager". Then select "Preferences" from the "Window" menu. A menu item named "Android" should be available on the left panel.

Once the "Android" menu item is available in the "Window" > "Preferences" dialog, select it. In the main panel, click the "Browse" button for the "SDK Location" field, and point it to the directory where you unzipped your Replicant 4 SDK. Then click "Apply" or "OK".

Next time you enter this dialog, a line saying "Android 4.0.3 / Android Open Source Project / Platform: 4.0.3 / API level: 15" should be present in the list of SDK targets.

Writing a "Hello World" app in Eclipse

Creating an Android Virtual Device

To run your app in an emulator, you need to create an Android Virtual Device. In Eclipse, choose "Window" > "Android SDK and AVD Manager" > "Virtual Devices" > "New" and fill in the properties of the virtual device as follows:

- Name: something descriptive like "AVD_for_Nexus_S"
- Target: choose "Android 4.0.3 - API level 15" from the dropdown menu
- SD Card: specify the size of an emulated SD card, alternatively browse for an existing SD card image
- Skin: better choose "Default" and the screen resolution of your physical device, e.g. "WVGA800" for Nexus S
- leave other values at defaults and click "Create AVD"
- if your disk is slow and you specified a large SD card image for creation, it may take a few seconds to complete

Creating a project

In Eclipse, choose "File" > "New" > "Project". In the tree of possible project types, a branch named "Android" should exist. Open it, select the project type "Android Project" and click "Next".

Enter a name for your project, e.g. "hello". For "Content", select "Create new project in workspace" and "use default location". The project will be created in your local Eclipse workspace directory, in a subdirectory corresponding to the project name.

Besides the project name, enter a friendly name for your application, e.g. "Hello World". Enter its package name, which can be either public (e.g. "com.example.hello") or private (e.g. "hello.test"). If you want the first piece of your application's user interface to be auto-created, leave the "Create Activity" checkbox checked and enter someting like "MainActivity" for the name of the "Activity" class to create.

Leave the minimum SDK version blank. Finally click "Finish" and your project should appear in Eclipse's left-hand projects tree.

Adding some code and resources into a project

To have your application's MainActivity class do something, consider adding some code. For example, you might want your application to have a button which closes it. In this sample, we specify the design of user interface elements in a separate XML resource file, so don't be surprised when you don't see anything related to their design here:

package hello.test;

import android.app.Activity;
import android.os.Bundle;
import android.view.View;
import android.widget.Button;

public class MainActivity extends Activity {

    @Override
    public void onCreate(Bundle savedInstanceState) {

        super.onCreate(savedInstanceState);
        setContentView(R.layout.main);

        Button buttonFinish = (Button) findViewById(R.id.buttonFinish);
        buttonFinish.setOnClickListener(new View.OnClickListener() {
            @Override
            public void onClick(View v) {
                finish();
            }
        });
    }
}

You may notice how the constructor of MainActivity calls "setContentView(R.layout.main)". In this statement, R is a special resource class, pointing to resources hosted in the "res" directory of your project. The "layout" class limits the choice to layout resources hosted under the "res/layout" while "main" is the name of a layout resource file "main.xml" located there.

We need to create this resource file now. I would recommend having it be like this:

<?xml version="1.0" encoding="utf-8"?>
<LinearLayout xmlns:android="http://schemas.android.com/apk/res/android" 
    android:orientation="vertical" 
    android:layout_width="fill_parent" 
    android:layout_height="fill_parent" 
    >
<TextView
    android:id="@+id/textInfo" 
    android:layout_width="fill_parent" 
    android:layout_height="wrap_content" 
    android:text="Click button to close app." 
    />
<Button android:id="@+id/buttonFinish" 
    android:layout_width="wrap_content" 
    android:layout_height="wrap_content" 
    android:text="Close" />
</LinearLayout>

Together, it makes sense. The "LinearLayout" element directs the application to fill the screen with its window ("fill_parent" for width and height). The "TextView" element displays a text field expanding to cover window width, but limits itself to content height ("wrap_content"). The "Button" element is a button named "buttonFinish", big enough to accommodate its content. Code obtains a handle to it by calling "Button buttonFinish = (Button) findViewById(R.id.buttonFinish);"), and creates an event listener for its OnClick event. This event listener calls "finish()" to close the app.

Running the app on an Android Virtual Device

Once you've coded your app, choose "Run" > "Run" in Eclipse. A dialog named "Android Device Chooser" will open, asking you to choose a device for it. Select the "Launch a new Android Virtual Device" checkbox and the virtual device you previously made, should become available for selection (select it and click "OK"). The virtual device will start booting up and will eventually run your app. Beware, on slow computers (e.g. an old model of Asus EEE PC) this can take minutes.

Running the app on a real Replicant device

1. Declare your app as debuggable. In the left-hand sidebar of Eclipse, your project's resource tree should contain a file resource named "AndroidManifest.xml". Right-click it and choose "Open With". Proceed by choosing either "Android Manifest Editor" or "Text Editor". If you preferred the manifest editor GUI, select the tab "Application" at its bottom. On the "Application" tab, set the field "Debuggable" to "true". If you preferred the text editor, append the property "android:debuggable="true" to the "<application>" element.

2. Enable USB debugging on your device, for example by choosing "Menu" > "Settings" > "Applications" > "Development" and checking the "USB Debugging" checkbox.

3. Verify that your device is visible. Prior to this, on Windows, you should install the ADB USB driver. On Mac, you should not need to configure anything. On some Linuxes (e.g. Ubuntu), you might need to add uDev rules (consult the "docs/guide/developing/device.html" file in your SDK directory, it contains detailed instructions).

Do the verification by issuing "adb devices" on command line. Make your your ADB (Android Debug Bridge) is included in your PATH variable. If it lists your device and its numeric ID, all should be fine. If it lists "?????????" for the ID and says "No permissions" under Linux, you might need to restart the ADB server (become root and issue: "adb kill-server; adb start-server", this presumes that ADB is also present in the root user's PATH).

4. Run the app. Without a customized run configuration, Eclipse should display the "Android Device Chooser" dialog, letting you choose.

5. Optionally, configure automatic deployment: if you want to automatically deploy to devices when they're attached, create a run configuration for your app, proceeding to select "Deployment Target Selection Mode: Automatic" in the "Target" tab.


Wiki License: Creative Commons BY-SA