Project

General

Profile

Replicant status

Added by pitr lolo about 1 month ago

Hello folks,

it's been long time since the replicant 6 was updated, I started to worry whether the project is still alive. I have the latest replicant 6 build running on my S3 as my main device for more than 1 year. The security patch level states November 2017 which is soon going to be 1 year old.

Is there any plan to update it ? What is the ETA ?

I know you're not paid for this and you rely on the sponsorship and you do it in your free time, but I'll have to consider to switch to another platform soon, in case nothing happens.

Thanks a lot for your work.

Cheers

Peter


Replies (12)

RE: Replicant status - Added by Joonas Kylmälä about 1 month ago

Hi,

the replicant-6.0-dev branch of manifest repo has currently latest security updates from month or so ago if you want to compile it yourself. This is the roadmap for the next (6.0 004) release: https://redmine.replicant.us/versions/41 that few of us are working on right now.

Any help with for example testing #1853, or #1832 would help. Also we are looking for people to test the new kernel for Samsung Galaxy Tab 2 – that is actually the biggest bottleneck right now.

RE: Replicant status - Added by pitr lolo about 1 month ago

Hi,

I'd like to use pre-compiled versions per release (to make it faster/simpler to update to next release), which I think most users want too, but good to know about dev branch - thanks for that !

I don't have Samsung Galaxy Tab 2 so I cannot test. But I can offer testing on S3 and I'm pretty decent at shell(bash) scripting if this helps. Just let me know whether I can help in these 2 areas.

Cheers

Peter

RE: Replicant status - Added by Andrés D about 1 month ago

There are unofficial nightly builds of the in-progress replicant 6.0 0004:

https://jenkins.minhas.io/nightly_builds/replicant/6.0-dev/

The i9300 images are probably the most tested. I you try it, feel free to report bugs or make comments on the IRC channel.

RE: Replicant status - Added by wellton costa about 1 month ago

Wow, I did not know that part. THANK YOU VERY MUCH. now updating on the i9300 to see the tests. Thank you =)

RE: Replicant status - Added by Daniel Kulesz about 1 month ago

I will be happy to help tesing on the Galaxy Tab 2 7.0. But is there an issue with the unofficial nightly builds? The most recent ones for the Galaxy Tab 2 7.0 are from end of September.

RE: Replicant status - Added by Amarpreet Minhas about 1 month ago

Hey just re-enabled the espressowifi/3g builds.

I had them disabled since we didn't seem to have any testers for them, but they will be built today and you should be able to test them out in a few hours.

Thanks for helping test everyone!

RE: Replicant status - Added by Daniel Kulesz about 1 month ago

Thank you, Amarpreet - I saw the builds. I will test the latest one on espresso-wifi and report back.

RE: Replicant status - Added by Daniel Kulesz about 1 month ago

I conducted a few first tests. Short overview:

- installation works
- install wizard has wording/label issues
- camera app crashes

For details, see the attached screenshot or visit my SystemTestPortal instance at the following URL:

https://demo.systemtestportal.de/kuleszdl/Replicant/dashboard/

I will add more test cases and issue further testing once I find more time.

Unfortunately, I must admit that I own the device since a few days and haven't played with it yet. Therefore, I discovered too late that I am unable to test wifi/bluetooth as the espresso-wifi needs a proprietary USB-OTG-plug to connect USB devices (I ordered such a plug now, should be here in a few days).

RE: Replicant status - Added by pitr lolo 3 days ago

Hey guys,

so after some time, I found a time to try to update my S3 with latest build on https://jenkins.minhas.io/nightly_builds/replicant/6.0-dev/i9300/20181118/. Unfortunately, it boots, but doesn't open an android UI, saying "Unfortunately, System UI has stopped". When I click ok, same error is displayed in a loop. This renders the phone to be unusable, how can I rollback please ?

Or is there any quick fix available ? :)
Anyone experiencing the same issue ?

Cheers

RE: Replicant status - Added by Joonas Kylmälä 2 days ago

pitr lolo wrote:

so after some time, I found a time to try to update my S3 with latest build on https://jenkins.minhas.io/nightly_builds/replicant/6.0-dev/i9300/20181118/. Unfortunately, it boots, but doesn't open an android UI, saying "Unfortunately, System UI has stopped". When I click ok, same error is displayed in a loop. This renders the phone to be unusable, how can I rollback please ?

Or is there any quick fix available ? :)
Anyone experiencing the same issue ?

Did you clear the cache in the recovery? I have always cleared also the user data when I tested the images, so that might be required, but let us know if clearing just the cache worked.

RE: Replicant status - Added by pitr lolo 2 days ago

Hi,

clearing the cache didn't help and led to the same situation. I had to Wipe data (keep media) which led to format of media (due to encryption I guess?). Anyway now it's working, thanks for that. I'll report any issues I encounter.

Cheers

RE: Replicant status - Added by Joonas Kylmälä 1 day ago

pitr lolo wrote:

clearing the cache didn't help and led to the same situation. I had to Wipe data (keep media) which led to format of media (due to encryption I guess?). Anyway now it's working, thanks for that. I'll report any issues I encounter.

Thanks for the report. We need to then do a wiki page to this like https://redmine.replicant.us/projects/replicant/wiki/MinorVersionUpgrade but name it MajorVersionUpgrade and make the instructions say to delete user data and back it up. That should be then linked somewhere in the release announcement.

    (1-12/12)