Project

General

Profile

Replicant SDK 4.4

Added by Dirk Zimmermann over 3 years ago

What are the necessary steps to move Replicant SDK 4.2 to Android 4.4? My background is that I want to develop for newer Android versions, but I don't like Google binaries on my machine and strange TOS.


Replies (3)

RE: Replicant SDK 4.4 - Added by Paul Kocialkowski over 3 years ago

Replicant is currently based off CyanogenMod 10.1.3/Android 4.2.2, so no 4.4 for now. What you can do is to get the latest code from either Omni/CyanogenMod or AOSP directly and rebuild the SDK (the same instructions as for Replicant's SDK should apply). It might be broken (it usually is), so take a look at the commits I introduced to fix it on Replicant 4.2!

RE: Replicant SDK 4.4 - Added by Dirk Zimmermann over 3 years ago

I've tried with AOSP (4.4.x needs oracle jdk 6, master can be built with openjdk 7 but is currently broken) and CyanogenMod 11 (currently broken), no success so far. I remember building AOSP master a couple of weeks ago, which worked but I could not find an SDK.zip. Which makes me appreciate even more the existence of Replicant 4.2, which at least enables me to build apps for 4.2 :) Btw., what was your background before you dived into developing Replicant?

RE: Replicant SDK 4.4 - Added by Paul Kocialkowski over 3 years ago

I'm not so surprised. The SDK is broken everytime, but isn't usually so hard to fix. The build target is usually sdk.

Btw., what was your background before you dived into developing Replicant?

I was mostly a free software enthusiastic and Openmoko user :)

    (1-3/3)