Project

General

Profile

ADB issue

Added by SPACE SPACE about 4 years ago

when attempting to install replicant to my i9100, after the following input:

adb sideload path/to/replicant-4.2-i9100.zip

I get the following error:

adb server is out of date. killing...
  • daemon started successfully *
  • failed to write data 'protocol fault (no status)' *

Not sure whats going on, cna anyone shed any light on what the problem is here?


Replies (7)

RE: ADB issue - Added by My Self about 4 years ago

To my shame, I don't using sideload and/or ADB, so I must confess that I don't know exactly what's the problem here.

First of all I wanted to refer to a workaround over the recovery mode:
http://redmine.replicant.us/projects/replicant/wiki/GalaxyS2I9100Installation#Preparing-the-device
and flashing the .zip file, which could be stored on a microSD card, regularly.

But I think to solve your problem you can just feed the search engine of your choice with the "adb server is out of date. killing" part. There are a lot of findings on my side. I've picked one out, which has tried to connect from another notebook and it works. So he reinstalled the Windows drivers from here: https://developer.android.com/tools/extras/oem-usb.html#InstallingDriver and it works on the affected notebook, too.
(By the way, you don't have specified your desktop operating system).

Good luck; hope it helps somehow.

RE: ADB issue - Added by SPACE SPACE about 4 years ago

I'm using Linux mint

RE: ADB issue - Added by Paul Kocialkowski about 4 years ago

I've had the same issue on some Samsung Exynos devices. It looks like sideload is broken on them, I'm not really sure why and I don't really have time to investigate i, but if you want to, I'd be happy to integrate a patch fixing that.

You can still either adb push the zip to the device, put it on the internal storage with the previous system or simply use an external card.

RE: ADB issue - Added by My Self about 4 years ago

I crawled the web a bit.
I've found absolutely nothing to be caused by the Android device. Every adb misbehavior could be fixed by modifying something on the adb of the connected desktop device.

I enabled [Android debugging] on my phone (i9100) and got a Linux Mint 17.2 64-bit PC, (and installed: "sudo apt-get install android-tools-adb").
Then I realized what you wanted to do; and I don't want to (re)install my device :)

So I pushed my Replicant image for testing reasons (successfully):
  • adb push replicant-4.2-i9100-HOMEMADE.zip /sdcard/replicant-4.2-i9100-HOMEMADE.zip
    4800 KB/s (165790864 bytes in 33.728s)
So I may ask:

All I can say at this point, it works for me out of the box, (but to be fair, I left the 'adb sideload' thing untested).

RE: ADB issue - Added by Paul Kocialkowski about 4 years ago

Apparently, it's only adb sideload in recovery that's a problem. The way it's implement is kind of a big dirty hack, it seems, so something must be going wrong with it at one point or another on exynos devices.

It's on my todo list to investigate it, but in no way a priority.

RE: ADB issue - Added by Thomas Kitchin about 4 years ago

Here's the solution (workaround):

In recovery:

1. Push the .zip to /preload (mount in Recovery first)
2. From adb shell, type:
echo '--update-package=/preload/replicant-4.2-i9100.zip >> /cache/recovery/command'
and then
reboot recovery

RE: ADB issue - Added by Bruno Dantas almost 4 years ago

I had decided to install Replicant on my i9100 using adb sideload instead of copying the installer to the device, and got majorly stuck due to this adb protocol fault issue. It seemed that the device was toast: adb sideload wouldn't work, could not reboot into the stock android (reboots always put me in recovery mode), couldn't mount /sdcard in recovery, Thomas's workaround above didn't work.

What finally worked for me was to mount tmpfs (basically part of the RAM) as the sdcard, copy Replicant zip file over to the "sdcard", then install the zip from the "sdcard". Here are the steps:

1. Boot the i9100 into recovery
2. Plug in usb cable into the i9100 and into your GNU/Linux computer
3. In GNU/Linux computer, open up a terminal and type:
adb shell mount -t tmpfs none /sdcard
4. Once the above command finishes (should be almost immediate), type this (replace "/path/to/" as appropriate, of course):
adb push /path/to/replicant-4.2-i9100.zip /sdcard
5. Back on the i9100, choose "install zip" -> "from sd card" then install replicant. Reboot and enjoy Replicant!

    (1-7/7)