Samsung Galaxy S - Recovery - Status 0 - Installation aborted‏

Added by Niels Heyvaert about 5 years ago

Dear forum,

I'm struggling to get Replicant installed on my Galaxy S.

Trying to go back to factory settings, my rooted phone got bricked. After fighting with the USB drivers via zadig I finally managed ODIN (very flaky tool !) to recognise the device. I managed to repartition the phone using the PIT file s1_odin_20100512.pit (from google code)

I then took the Replicant recovery image and installed that image. It now states CWM-based recovery v6.0.4.6 and operates without errors when mounting unmounting etc.

Now, when in recovery mode and pushing (adb) Replicant (which I renamed to I always get an error stating:

E:Error in storage sdcard0
(status 0)
Installation aborted.

I've looked at various combinations, rebooting reconnecting, re-wiping, toggling signature verif, sideloading vs pushing, etc. etc.

So far I have not found a root cause or way to avoid the error and continue with the installation.

Any idea what is causing the error message Status 0 ?

After a fresh reboot in recovery and going to Advanced-show log, I can see:

I:Skipping execution of extendedcommand, file not found...
I:Cannot load volume misc
I:Can't partition non mmcblk device: devices platform s3c-sdhci.0 mmc_host mmc0

Thanks in advance for your feedback.

Replies (2)

RE: Samsung Galaxy S - Recovery - Status 0 - Installation aborted‏ - Added by Joshua Bowren about 5 years ago

You may have messed up the partition table when repartitioning the phone. I have no way of knowing for sure, but just suggesting that might be the issue.

The person in this post had a similar issue. They fixed it by flashing back to stock, which fixed the sdcard parition. Then they were able to install Replicant normally.

If you want to debug updater-script while installing a zip package, you could add debug messages to updater-script to see how far it gets. I think you should be able to add ui_print("Some Message") in order to print while updating. Unfortunately I had not had any luck with this, but I think it should work in general.

RE: Samsung Galaxy S - Recovery - Status 0 - Installation aborted‏ - Added by Niels Heyvaert almost 5 years ago


Flashing back to stock ROM, including PIT repartitioning, indeed resolved the issue. While performing these tasks I've learned Odin is a very sensitive/unstable tool. It only worked once on my desktop and I never got it to work afterwards. It appears to be working on my laptop, for the time being. The time I've wasted getting this to work is enormous... Anyway, the problem was not residing on the Replicant side.

Thanks for the hint and pointer.