Project

General

Profile

libusbx error in installing replicant

Added by Nicolas BROSSE almost 6 years ago

Hi there,

I hope this is the correct place to ask for help. Otherwise don't hesitate to tell me where i should post.

I really wish to install replicant on my Samsung Galaxy tab 2 10.1 GT5110 tablet.
I followed the installation guide until the "installing the image" step and then i had the libusbx error i reproduced in the file attached. It seems i cannot access my device for some reason i don't understand.

I spent quite a lot of time trying to resolve the problem by myself by searching on forums (xda...) without succeeding.

My desktop PC is a mac under OSX 10.9 on wich i installed heimdall sdk as requested through the installation guide.

Here is what i did before posting here, ending with the same error message :

  • precision : i am not root yet on my device. Don't know how to do it (fastboot ?)
  • i prompted the "sudo heimdall flash --BOOT recovery.img --RECOVERY recovery.img" command within the good repertoire with usb debbuging on and off on the device. Not working.
  • i did not find where to turn the MTP protocol off on my device. Maybe that should help.
  • i uninstalled kies on my device and on my PC for it worked for some people on forums. Nope for me.
  • i went through a wipe data/factory reset with power + volume down buttons on my device and then tried to install replicant again. Not better.

If it can help : before wanting to install replicant (because before knowing replicant existed, found that idea on fsfe.org) i backed my files up with helium from cyanogen mod. I also tried to use rom manager from cyanogen mod without success because i was not root on my device.

Well, that is quite all.

In wich direction should i go to succeed in installing replicant ? All help welcome here.

Thank you.


Replies (4)

RE: libusbx error in installing replicant - Added by Linus Drumbler almost 6 years ago

For one, you will need to be running GNU/Linux on your computer to install Replicant. See instructions for installing one of those systems elsewhere.

RE: libusbx error in installing replicant - Added by Nicolas BROSSE almost 6 years ago

Hello,

Do you mean i cannot install Replicant on my tablet BECAUSE i do not have a GNU/Linux system installed on my computer ? I find that hard to believe.

RE: libusbx error in installing replicant - Added by Paul Kocialkowski almost 6 years ago

Well, our installation instructions mention that your computer must be running a GNU/Linux operating system for the sake of not having to provide informations for other systems such as Windows or Mac OS. However you can obviously manage to get it done with Mac OS (even though it always gives me a strange feeling to see someone trying to install Replicant with a proprietary system, but obviously, you do what you prefer). I don't know about your libusbx error, you should ask Heimdall's developers, this is not a Replicant-related issue anyway.

RE: libusbx error in installing replicant - Added by Nicolas BROSSE almost 6 years ago

First, i would like to thank both of you for having responding to me.

It is true that you mentionned the GNU/Linux operating system in the installation instruction, but, hey, what can i say ; i already have a Mac OS running on my computer. I think wanting to install replicant on a tablet with a Mc OS is "better" than still continuing with Mac OS and Android but, of course, "worse" than having GNU/Linux and Replicant. Well, i feel that i have to go with what i have and i just wanted to start with my tablet.

Because you mentionned Heimdall in the installation instructions and they say on their website that it can be running on Mac OS platforms, i was assuming not to have problem with the replicant installation at all. But, you're certainly right here, it is maybe a question i should ask on their forum, not on yours. And i will. I just did not know where to begin since the error message did not ring any bell to me.

I am still wanting to install replicant and will give efforts in that direction.

Good day.

    (1-4/4)