Galaxy S2 i9100, Heimdall not working properly

Added by Noah Neuhoff about 8 years ago

I'm running Debian GNU/Linux with all prerequisites done and this is a used device I just bought online. Whenever I run the heimdall flash, I get this:

heimdall flash --kernel recovery.img
Heimdall v1.4.1

Copyright (c) 2010-2014 Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection...
Detecting device...
ERROR: Failed to detect compatible download-mode device.

Any suggestions?

Replies (1)

RE: Galaxy S2 i9100, Heimdall not working properly - Added by My Self almost 8 years ago

I had exactly the same error with the same heimdall version on an Arch based OS.
I temporarily installed Linux Mint ( on an my second computer an it worked great (with the same i9100 and the same data cable).

I've found that the CM project also recommends to use the previous version: (in the "Note: Flashing with heimdall" section),
and/or compile it yourself:

Just give it a try...