trouble upgrading my Galaxy S2 from 4.2 to 6.0

Added by Scott Bonds 5 days ago

I have a Galaxy S2 running Replicant 4.2. I copied the new 6.0 image to an SD card, put the SD in the phone, did a factory reset, then tried to "choose zip from sdcard" on the recovery mode menu. Here's what I see:

CWM-based Recovery v6.0.3.6
Warning: No file_contexts

-- Installing. /sdcard/replicant-6.0-i9100.zip
Finding update package...
Opening update package...
Warning: No file_contextsTarget: samsung/GT-I9100/GT-I9100:4.1.2/JZ054K/I9100XWMS2:user/release-keys
detected filesystem ext4 for /dev/block/mmcblk0p10
detected filesystem ext4 for /dev/block/mmcblk0p9
ApplyParsedPerms: lsetfilecon of /system/lost+found to u:object_r:system_file:s0 failed: Operation not supported on transport endpoint
set_metadata_recursive: some changes failed
E:Error in /sdcard/replicant-6.0-i9100.zip
(Status 7)
Installation aborted.
No files found.

There was a long pause between the 'detected' and 'Apply' lines...I want to say it was a number of minutes. After rebooting the phone I see the Samsung splash screen with a triangle yellow exclamation point and then the recovery screen shows. So, I went back into recovery mode and restored my backup, but that didn't fix it. I then reinstalled the 4.2 firmware using the same process I attempted for 6.0, rebooted, and everything worked, just on 4.2 instead of 6.0.

What am I doing wrong in my attempt to install 6.0? Do I need to install the new recovery firmware in order to install 6.0?


Replies (2)

RE: trouble upgrading my Galaxy S2 from 4.2 to 6.0 - Added by Joshua Bowren 4 days ago

Scott Bonds wrote:

Do I need to install the new recovery firmware in order to install 6.0?

Yes, this is mentioned in Wolfgang's original Replicant 6 S2 development post. The procedure is pretty much the same as installing for the first time. Worked fine for my I9100.

(1-2/2)