[solved] stuck on replicant logo

Added by Fil Lupin almost 7 years ago

Hi there,
following a EFS problem, I tried to install an old 4.2-0004 version on my i9300.

Here are the steps I followed :

heimdall flash --BOOT recovery.img --RECOVERY recovery.img
Heimdall v1.4.1

Copyright (c) 2010-2014 Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...

Initialising protocol...
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device's PIT file...
PIT file download successful.

Uploading BOOT
BOOT upload successful

Uploading RECOVERY
RECOVERY upload successful

Ending session...
Rebooting device...
Releasing device interface...

Then reboot in CWM mode and

adb sideload
loading: ''
sending: ''  100%

However, I am now stucked at startup with Replicant logo.
I would like to avoid to clear data in CWM mode. My goal is just to get back my EFS and get back my phone to work.

Do you know if I can either:
+ save outside from the phone the data partition from CWM recovery mode
+ avoid to erase data partition while installing replicant

Thank you.

Replies (5)

RE: stuck on replicant logo - Added by Fil Lupin almost 7 years ago

Since I need my phone back, if anyone knows that the answer is no at any of these two question, it would be kind to tell me.
It would avoid me to wait for an impossible solution.

RE: stuck on replicant logo - Added by Wolfgang Wiedmeyer almost 7 years ago

If the data partition is not encrypted, you could try to mount it in the recovery. I think the Replicant 4.2 recovery had an option for that. Then you can access it with ADB.

You can always try to install Replicant without a factory reset. There is nothing preventing you from doing that. But you have to expect that some data is incompatible and causes weird and unpredictable behavior. It may even prevent the device from booting. Switching between different versions of the same major Replicant release should not cause such issues, but for everything else it's pretty much guaranteed.

Even if the device hangs at the logo, ADB may already been started and you might be able to use ADB.

RE: stuck on replicant logo - Added by Fil Lupin almost 7 years ago

Thank you for your answer Wolfgang.

In fact, it seems to me I can not get out currently from CWM recovery mode before reinstalling replicant.

I tried to reinstall replicant 4-2 to keep exactly the same version but it seems to bug.

When I try to mount /external_sd, I got the following :

error Error liybtubg /external_sd

Note this is the only partition I can not mount.

So when I try to backup, I got:

Can't mount backupo path

Whatever, when launching adb root after adb kill-server as mentionned, I got following output:

#adb kill-server
#adb root
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
error: device unauthorized.
This adbd's $ADB_VENDOR_KEYS is not set; try 'adb kill-server' if that seems wrong.
Otherwise check for a confirmation dialog on your device.

Same output with "adb shell" command. :s

RE: stuck on replicant logo - Added by Fil Lupin almost 7 years ago

After checking logs from CWM, here is the output :

CWM-based Recovery v6.0.3.6

I:Checking for extendedcommand...
I:Skipping execution of extendedcommand. file not found...
mount: mounting /dev/block/mmcblk1p1 on /external_sd failed: No such file or directory
Error mounting /external_sd
I:Can't partition non-vfat: datamedia
I:Can't partition non-vfat: auto
I:Can't format unknown volume: /emmc

RE: stuck on replicant logo - Added by Fil Lupin almost 7 years ago

I finished building replicant 6 and install it following steps described on page and it works!
Thank you very much for your time Wolfgang. :)