Project

General

Profile

Problem installing Replicant on Galaxy S3: ADB "device not found"

Added by Boaz Boaz about 1 year ago

Following the instructions here: https://redmine.replicant.us/projects/replicant/wiki/GalaxyS3I9300Installation , everything worked until I got to the ADB sideload. I selected "Apply update", and then "Apply from ADB", and then typed the command as in the instructions, and I got:

  • daemon not running. starting it now on port 5037 *
  • daemon started successfully *
    error: protocol fault (no status)

I tried again and got:

error: device not found

A third time:

error: protocol fault (no status)

Fourth and subsequent attempts yeild:

error: device not found

I tried unplugging the device from the computer, rebooting it, and plugging it back in, each time "error: device not found", except once (apparently randomly) it gave "protocol fault (no status)"

I thought about going back to the other method, using the internal storage, but transferring the file seems to require an Android operating system running, and if I understand correctly installing the recovery image replaced the operating system (no?).

So anyway, due to this ADB error, I'm stuck in the installation process :(

Any help greatly appreciated!

Thanks in advance.

Boaz