(SOLVED) Can't Exit Recovery Mode

Added by Anony Mous almost 5 years ago

EDIT: This has been solved, see the edit below.


I am trying to install Replicant on my Galaxy Nexus (I9250). I had successfully used Heimdall to install the recovery image. I was then following along with the installation instructions (, when I got to the part about actually installing the operating system. The three options I have are to download the installation files directly onto the device, use a microSD card, or to use a computer to put the installation image on the internal storage by using a computer. The problem is, the Galaxy Nexus doesn't have a microSD port, and both other options require Android to be running in order to get the Replicant image on the internal storage. But, whenever I reboot the phone, I am returned to the Replicant recovery page. How do I exit recovery mode and return to normal Android, so that I can copy the image over from my computer to the phone? Or, if there is another way to copy it over while in recovery mode, how do I do that?

If you have to download the installation image onto the Nexus BEFORE installing the recovery image, the instructions should probably say so.

EDIT: I was able to solve this problem by using adb sideload. From the Replicant Recovery main menu, select the option that says "Apply Update", then from there, select the one that says "Apply from ADB". Once you click that, move over to your computer (assuming the USB cable is already plugged into it and your Nexus), make sure adb is installed, open up a terminal, and run:

adb sideload /path/to/replicant/

Then wait, and it will install the image. From there, you can continue with the installation instructions, and it should work. If you're stuck in the same scenario I was, I hope this helps.

Replies (3)

RE: (SOLVED) Can't Exit Recovery Mode - Added by Emmett Brown almost 5 years ago

Hi !

You can use ADB tool.

When your device is in the recovery mode
1. Choose "Apply Update"
2. Choose "Apply from ADB
3. Connect your device on your computer with USB
4. On your computer, open a terminal
5. cd <folder where is located>
6. adb sideload

And that's it.

I think it could work.
Let us know if you succeed !


RE: (SOLVED) Can't Exit Recovery Mode - Added by Kurtis Hanna almost 5 years ago

Thanks for posting here about your problem and solution. It is a good reminder for us to update our installation documentation: