Project

General

Profile

i9300 odd behaviour: Replicant 4.2 working, Replicant 6.0 stuck in early bootloop

Added by green blue 6 months ago

Hello,

today I received an SIII (i9300) with CyanogenMod preinstalled (obvs. an old version, but working fine). I successfully installed the Replicant 6.0 recovery and sideloaded the 6.0 0003 image, but the device is now stuck in an early bootloop. The Samsung Galaxy SIII screen appears for ~15 seconds, then it goes to black for a couple of seconds, then Samsung screen again. No Replicant logo. Afterwards, I tested various other images:

Boot loop:
- Replicant 6.0 0003
- twrp 3.2.3 + LineageOS 14.1 (20191115)
- twrp 3.2.3 + LineageOS 16.0 (20190710)

Working:
- Replicant 4.2 0004
- twrp 3.2.3 + CyanogenMod 11 (20160115)

This behaviour is stable and seems to be systematic. Old stuff works, newer images fail to boot very early, no Replicant/LineageOS screens appear. The baseband version is I9300XXUGNA8, which is probably not the issue, as I have multiple other i9300s with the same version and they run everything perfectly.

What could be the issue, faulty partition layout or something? Do I need to update another hidden(?) firmware to make newer images work? I could provide logs etc., but I don't know where to start. I know how to use the terminal and adb, so I could run some commands and post the output here.

Thanks!


Replies (1)

RE: i9300 odd behaviour: Replicant 4.2 working, Replicant 6.0 stuck in early bootloop - Added by Kurtis Hanna 5 months ago

Hello green blue,

My best advice is to download a trustworthy stock i9300 ROM image and flash it using this command:

$ heimdall flash --BOOT boot.img --CACHE cache.img --HIDDEN hidden.img --RADIO modem.bin --PARAM param.bin --RECOVERY recovery.img --BOOTLOADER sboot.bin --SYSTEM system.img --TZSW tz.img

After that flash Replicant again in the normal way and then let us know if your issue has been resolved.

The rough thing is that I don't currently know where you can download a trustworthy stock i9300 ROM image. I did some research today on this front by looking at https://opensource.samsung.com/uploadSearch?searchValue=i9300 but I didn't get very far.

Cordially,
Kurtis

    (1-1/1)