Project

General

Profile

ERROR: Partition "boot" does not exist in the specified PIT.

Added by Santiago Xavier 3 months ago

Help? My device is Samsung Galaxy SIII (GT-I9300) and my computer is a Ubuntu 20.04

heimdall flash --boot Descargas/recovery-i9300.img --recovery Descargas/recovery-i9300.img
Heimdall v1.4.2

Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna
http://www.glassechidna.com.au/

This software is provided free of charge. Copying and redistribution is
encouraged.

If you appreciate this software and you would like to support future
development please consider donating:
http://www.glassechidna.com.au/donate/

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...

Initialising protocol...
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device's PIT file...
PIT file download successful.

ERROR: Partition "boot" does not exist in the specified PIT.
Ending session...
Rebooting device...
Releasing device interface...


Replies (4)

RE: ERROR: Partition "boot" does not exist in the specified PIT. - Added by dl lud 3 months ago

You have to write both BOOT and RECOVERY in upper case:

heimdall flash --BOOT Descargas/recovery-i9300.img --RECOVERY Descargas/recovery-i9300.img

RE: ERROR: Partition "boot" does not exist in the specified PIT. - Added by Santiago Xavier 3 months ago

dl lud wrote:

You have to write both BOOT and RECOVERY in upper case:

[...]

It went well but... The installation failed.
Here are the images.

RE: ERROR: Partition "boot" does not exist in the specified PIT. - Added by dl lud 3 months ago

This new issue you are having now, Failed to verify whole-file signature, suggests that the version of Replicant's Recovery is different from the version of the Replicant system zip.
Please try to install both the Replicant 6.0 0004 rc1 Recovery and system image from: https://ftp-osl.osuosl.org/pub/replicant/images/replicant-6.0/0004-rc1/images/i9300/

RE: ERROR: Partition "boot" does not exist in the specified PIT. - Added by Santiago Xavier 3 months ago

dl lud wrote:

This new issue you are having now, Failed to verify whole-file signature, suggests that the version of Replicant's Recovery is different from the version of the Replicant system zip.
Please try to install both the Replicant 6.0 0004 rc1 Recovery and system image from: https://ftp-osl.osuosl.org/pub/replicant/images/replicant-6.0/0004-rc1/images/i9300/

Thanks for the help, those solutions worked and I already have Replicant on my smartphone.
I love Free Software and that's why I really wanted something like Replicant because I find it a very interesting project.

Thank you very much.

    (1-4/4)