Project

General

Profile

Galaxy S II ( GT-i9100 ) installation problems / stuck at logo

Added by comfy table 6 months ago

Just yesterday I tried to install Replicant in Linux using heimdall. First I flashed the Recovery through heimdall ( recovery-i9100.img ) and then the image itself ( replicant-6.0-i9100.zip ) on the SD card from within Recovery. Everything worked in terms of installing the actual files on the device, or so it seems.

THE PROBLEM
I let the device boot after flashing the image. Every single time it stops at the Replicant logo and doesn't move on from there. I even waited an hour once or twice.

OTHER THINGS I TRIED
I tried to install the RC4 release too (result: it failed verification or words to that effect, despite importing all necessary keys). And also the 4.2 release. The 4.2 release in the only one that booted 'properly' you could say, but wifi and bluetooth were not working. I didn't test anything else. I pretty much gave up at this point.

SECONDARY PROBLEM
Cannot access Recovery at all manually (by pressing the buttons). Recovery only works (once) through heimdall (when it installs recovery and reboots the device into Recovery).

ADDITIONAL INFO
The device had an unofficial LineageOS installed prior to the Replicant attempts.
I don't know what I am missing and would be very grateful for any help in getting Replicant on this device starting & running properly.


Replies (2)

RE: Galaxy S II ( GT-i9100 ) installation problems / stuck at logo - Added by Denis 'GNUtoo' Carikli 5 months ago

Which Replicant 6.0 versions did you try (0003, 0004-rc5, etc) ?

Denis.

RE: Galaxy S II ( GT-i9100 ) installation problems / stuck at logo - Added by Echedey López Romero about 1 month ago

Good afternoon from Spain,

I have registered in this Redmine instance from Replicant after searching and finding this report.

I am experimenting the same issue in a clean installation as it is described here.

I am using the default installation method for the Samsung Galaxy S2 described in this same wiki in https://redmine.replicant.us/projects/replicant/wiki/Installation and https://redmine.replicant.us/projects/replicant/wiki/RecoveryInstallationWithHeimdall#Install-the-recovery-image.

I have tried 0003 release only and verified the checksums correctly.

Edited:

Yes, I didn't fall in the issue of thinking that the image was installed when installation got stuck for a few minutes and disconnected, I waited until it released that was successful.

Edited 2:

I forgot to add that before to this, I was using the last build of LineageOS 14.1 successfully and then I tried DivestOS and Replicant which finished in bootloop in the logo or animation in both cases.

    (1-2/2)