Project

General

Profile

[solved] New Replicant-4.2 installation does not reset content

Added by Fil Lupin 7 months ago

Hello,
while installing a Replicant-4.2 device, I removed `/data/data` by bad command.
I then decided to completely reinstall the device following RecoveryInstallationWithHeimdall and then Installation
However, when rebooting, the device still contains app installed during the first bad installation.

I wiped data and cache, do you know how to format and factory reset a device with replicant 4.2?
I do not find the page where is is detailed (I tried https://redmine.replicant.us/projects/replicant/wiki/GalaxyS3I9300Installation/9 but wipe data/factory after installation is not sufficient).

Do you have any idea how to clean my installation?
Regards


Replies (1)

RE: New Replicant-4.2 installation does not reset content - Added by Fil Lupin 7 months ago

If /data (USERDATA) contains also app data, when I execute in recovery a `data/factory reset`, the output is
```
-- Wiping data --
Formatting /data...
Error mounting /data!
Skipping format...
Formatting cache...
Formatting /sd-card/.android_secure...
Error mounting /sdcard/.android_secure
Skipping format...
Data wipe complete.
```
When in advanced menu, I tried to manually mount /data, I got
---
Error mounting /data!
---
When I tried to manually format /data, I got the same problem.

Do you have any idea how to solve this problem.

I finally succeeded when in advanced menu, I tried to `format /data and /data/media` which output
---
Formating /data...
Done.
---
Reboot prooved the formating was successful and old apps disappeared.

    (1-1/1)