Project

General

Profile

libusb(x) errors while trying to upload images to the Galaxy I9300

Added by Dmitry Samoyloff over 5 years ago

Hi,

I'm trying to install the Replicant on my I9300, using Heimdall from https://bitbucket.org/benjamin_dobell/heimdall/downloads/ubuntu12.10-heimdall_1.4.0-0_amd64.deb on Trisquel 6.0. The installation instructions I'm using are at http://redmine.replicant.us/projects/replicant/wiki/GalaxyS3Installation .

My problem is rather heimdall/libusb(x)-related but maybe someone here experienced it too.

Running heimdall, I'm getting the following:

$ sudo heimdall flash --BOOT recovery.img --RECOVERY recovery.img

Heimdall v1.4.0

Copyright (c) 2010-2013, Benjamin Dobell, Glass Echidna
http://www.glassechidna.com.au/

This software is provided free of charge. Copying and redistribution is
encouraged.

If you appreciate this software and you would like to support future
development please consider donating:
http://www.glassechidna.com.au/donate/

Initialising connection...
Detecting device...
Claiming interface...
Attempt failed. Detaching driver...
Claiming interface again...
Setting up interface...

Initialising protocol...
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device's PIT file...
PIT file download successful.

Uploading BOOT
0%libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12

ERROR: Failed to send file part packet!
ERROR: BOOT upload failed!

Ending session...
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
libusb:error [submit_bulk_transfer] submiturb failed error -1 errno=12
ERROR: Failed to send end session packet!
Releasing device interface...
Re-attaching kernel driver...

I've also tried to build heimdall (and libusbx, as it wants it) myself with the same result. I even tried the git versions of both heimdall and libusbx, but in vain.

BTW, the "--BOOT recovery.img" fragment of command line confuses me a little, should it be "--BOOT boot.img" instead? Anyway, the latter one didn't help either.

What else should I check or try to overcome this problem? (I can't find Heimdall forum or mailing list anywhere.)


Replies (2)

RE: libusb(x) errors while trying to upload images to the Galaxy I9300 - Added by Paul Kocialkowski over 5 years ago

I experienced the same errors and didn't find a solution to it. The problem simply disappeared when I updated my laptop to Debian jessie (it was happening with wheezy). On Trisquel 6.0, both the packages self-built binaries work. Maybe try to build heimdall v1.4.0 RC1 or RC2, one may work better than the other.

Also note that heimdall is packaged in Debian and apparently it works fine. Maybe they have a patch for that issue?

BTW, the "--BOOT recovery.img" fragment of command line confuses me a little, should it be "--BOOT boot.img" instead?

No it shouldn't! You want to boot recovery first, not the kernel when the system is not yet installed!

RE: libusb(x) errors while trying to upload images to the Galaxy I9300 - Added by Dmitry Samoyloff over 5 years ago

I tried to use heimdal-1.4.0 + libusbx-1.0.17 both compiled on my old Trisquel 4.1 machine and it worked! Yay!!

    (1-2/2)