where is gpsd located (galaxy s3)?

Added by robin p over 4 years ago

i have a galaxy s3 with replicant installed, unfortunately the gps is a stupid proprietary only device for which there is no free software implementation. so, i would like to investigate the possibility of using an external gps device, either via usb (preferred) or bluetooth. there are many available, mostly they interface via gpsd. but, where is it, i can't find it anywhere in /system and tab-completion doesn't bring it up on the command-line. /etc/init.d/ would be the usual location, but it's not there either.

on the other hand, if i'm going about this entirely the wrong way, suggestions for other directions are welcome.


Replies (4)

RE: where is gpsd located (galaxy s3)? - Added by E D over 4 years ago


I do not think it is provided by Replicant.

You should look at the cyanogenmod image for the galaxy S3, also googling "gpsd" with "galaxy s3" and "replicant" might lead you directly to people
having already solved the problem, at least for replicant previous versions.

As for me, I successfully installed gpsd on my galaxy s3, but had been unable to make any gps application run correctly.

Finally removed it as it is not my main concern with replicant to have gps working.

Let me know if you are able to run a gps application.

Hopes this helps.

Best regards

external gps receiver - Added by name1 name2 over 4 years ago

concerning the use of an external bluetooth gps receiver:
BlueGps from the F-Droid store
worked for me (without gpsd / galaxy s2)

RE: where is gpsd located (galaxy s3)? - Added by E D about 4 years ago


Could you tell which bluetooth gps receiver you use with the BlueGps app ?


RE: where is gpsd located (galaxy s3)? - Added by robin p about 3 years ago

I did some research into this and came to the conclusion that samsung incorporated gpsd into proprietary code, which is permitted as gpsd is BSD-licenced.

I am unwilling to use Samsung's proprietary code (it looks very dubious, according to this blog [1]) so I have asked the maintainers of termux to include it in their package repo [2].


"GPS doesn’t work by default. After installing /system/bin/gpsd (MD5 6757ed2e2a283259e67c62e6b2b9cfef), /system/lib/ (MD5 a836df0f947d2aa2ef20dcb213317517), /system/lib/hw/ (MD5 1ea1d67f297dd52d59d40dbad9b02a0a) it works. This is code that runs on the main CPU, and even more alarming, it embeds a copy of OpenSSL and talks to various online servers for A-GPS, and is thus a likely (and probably not too challenging) attack vector for anyone wanting to remotely exploit any phone."