Project

General

Profile

No USB drive in Replicant 6

Added by Flo Debian 9 days ago

I have a SII and when I attach an USB flash drive to the phone I cannot see it. I haven't found any settings to make this possible. Could anyone give me some hints?

I had another SII with Replicant 4 before and I can remember that attaching an USB flash drive just worked.

Thank you.


Replies (6)

RE: No USB drive in Replicant 6 - Added by Fil Bergamo 9 days ago

Hi,

Are you using an OTG cable or OTG adapter to connect the drive?
You need one of those to make your phone act like a USB host.

RE: No USB drive in Replicant 6 - Added by Flo Debian 9 days ago

I'm using an OTG Adapter for that.

RE: No USB drive in Replicant 6 - Added by Fil Bergamo 8 days ago

Could be missing drivers/firmwares?

Have you tried different USB sticks or other peripherals?
..just to exclude USB itself...

No other thoughts on that.. sorry..

RE: No USB drive in Replicant 6 - Added by Flo Debian 7 days ago

It worked with my previous SII. But there I was using Replicant 4 .

I don't know if the necessary driver got lost when jumping from R4 top R6.

Or is it a permission problem? Or a setting somewhere?

This time I have tried that with different peripherals. And the usb outlet of the phone at least works with adb.

RE: No USB drive in Replicant 6 - Added by robin p 6 days ago

Flo Debian wrote:

It worked with my previous SII. But there I was using Replicant 4 .

I don't know if the necessary driver got lost when jumping from R4 top R6.

Or is it a permission problem? Or a setting somewhere?

This time I have tried that with different peripherals. And the usb outlet of the phone at least works with adb.

have you tried running "lsusb" to see what happens when you plug it in? or dmesg (say within the "System Monitor" app)?

it may be an unusual drive which requires particular drivers beyond the usual USB drivers.

installing termux might be useful, it includes lots of tools for examining and working with your system, I find it far better than the stock replicant 6 command-line tools

RE: No USB drive in Replicant 6 - Added by Flo Debian 2 days ago

When I use lsusb, a new bus shows up when I insert the flash drive. Every time.

And I realized that sometimes it's working and the usb sign shows up at the notification bar. Maybe every 15 times I plug in the flash drive.

Maybe my phone has a hardware problem at its usb outlet. The same drive always works with my old SII (Replicant 4).

And yes, I am using termux, too. It's great but I haven't found a way to open a second window, yet.

    (1-6/6)