Project

General

Profile

usb ethernet not working

Added by Jorge Gomez 10 months ago

I wanted to ask:

Does a usb ethernet adapter currently work with Replicant 6.0003 and a Galaxy Tab 2 7.0 GT-P3113?

I tried to connect my adapter and it doesn't work. I have root enabled.

Any help would be greatly appreciated as I am trying to decide whether to return my ethernet adapter or keep it. I wasn't able to find any documentation on replicant.us regarding the use of a usb ethernet adapter. It looks like the one I have is usb 3.0.

The ethernet adapter I am using is this one:

https://www.amazon.com/gp/product/B013G4C8RE/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

Any help is greatly appreciated!

best,

Jorge


Replies (3)

RE: usb ethernet not working - Added by Kurtis Hanna 7 months ago

Jorge,

I don't believe that this is currently working, but I would love to see support for this added.

It is likely that support for this will become much easier to add in the near future for the Note 2 and Galaxy S3 when they start running with the mainline linux kernel. I really have no idea how hard it would be to add this feature for the Galaxy Tab 2. I don't think that the Replicant devs have really looked into it yet.

I was also excited about this potential feature a number of months back when I saw the product that you linked to existed for the Note 2.

By the way, can you confirm that Replicant 6.0003 runs just fine on the Galaxy Tab 2 7.0 GT-P3113? Someone just asked about that exact model on the mailing list.

cordially,
kurtis

RE: usb ethernet not working - Added by Chad Vellacott 7 months ago

Jorge and Kurtis,
You both may have already noticed, but on this page,

https://redmine.replicant.us/projects/replicant/wiki/ReplicantStatus#fn1

footnote-1 marks that SOME USB-WiFi-adapters, work with Replicant 6.0 (0003?), for all of the supported devices.  (not sure about models x113.  Like Kurtis referred to, I asked some thing about those models, on the mailing-list.  Compatibility with Replicant 6.0 is still a question.)

https://redmine.replicant.us/projects/replicant/wiki/WifiAdapter

has more details on using Replicant 6 with USB-WiFi, like (a) needing an OTG-cable, and (b) mentioning certain of the libre-friendly adapters from "ThinkPenguin" and "TechnoEthical".
If WiFi works that way on Replicant 6.0, then may-be wired (Ethernet) does too ??
Kurtis, does the Linux-kernel handle WiFi and Ethernet much differently?
Jorge, if you prefer wired, then

https://www.thinkpenguin.com/gnu-linux/penguin-usb-20-hi-speed-10100-fast-ethernet-network-adapter

MIGHT be more-likely to work than that adapter from Amazon, since "ThinkPenguin's" is said to be libre-compatible, and USB 2, and that company seems to strive to only sell devices with high-compatibility.  You could ask "ThinkPenguin".  If they have a Replicant-device available, they might gladly test for you (us) whether their USB-Ethernet-adapter works with Replicant.  (Their adapter has 2 versions.  Version 1 cost more and offered support for more systems.  And Sales said that version 2 was good quality but that version 2 was even better quality.)
(If you are fine with wireless, then products from both "ThinkPenguin" and "TechnoEthical"  are mentioned on that page regarding WiFi on Replicant.)
Yay for libre computing.
Sincerely, Chad.

RE: usb ethernet not working - Added by Kurtis Hanna 6 months ago

Chad,

I'm almost positive that the x113 models work just fine with Replicant 6.0

WiFi with Replicant 6.0 works with RepWifi, but wired Ethernet does not. I've already tried. I don't know what is different about it in the code, I just know that it currently isn't supported.

https://tehnoetic.com/tehnoetic-wireless-adapter-gnu-linux-libre-tet-n150 is confirmed to work with RepWifi on Replicant 6.0

My hope is that the upcoming mainlining of the kernel for the S3 and Note 2 will make it fairly easy to add usb ethernet support in Replicant.

Cordially,
Kurtis

    (1-3/3)