Project

General

Profile

S3 i9300 replicant 6 : osmand app fails due to "native renderer not available"

Added by E D 10 months ago

Hello,

Since the latest replicant 6.0 update on my S3 i9300, the app OSMand fails to display maps claiming that the native renderer on my phone is not available (!)

OSMand app sometimes just crashes sometimes launches but refuses to display maps.

I never had this issue before. What could I do ?

Thanks in advance for your help.


Replies (3)

RE: S3 i9300 replicant 6 : osmand app fails due to "native renderer not available" - Added by Xan VFR 9 months ago

Hi!

Which version are you using? I'm using OsMand 2.8.2 (2.9 went out just a couple of days ago; still not available in F-Droid) without a glitch.

Do you have the maps updated?

RE: S3 i9300 replicant 6 : osmand app fails due to "native renderer not available" - Added by E D 9 months ago

Hi

Thanks for your answeer,

I was finally able to make OSMand display maps, I had to change one setting : use the android code (slower) than the native one. Indeed this was the error message (native rendering not available).

Regards

RE: S3 i9300 replicant 6 : osmand app fails due to "native renderer not available" - Added by Xan VFR 9 months ago

E D wrote:

I was finally able to make OSMand display maps, I had to change one setting : use the android code (slower) than the native one.

Do you mean Global settings -> Safe Mode? I have this option unchecked, so I guess I'm not using Android code, and I have no problem.

Anyhow, glad to know it's working for you.

    (1-3/3)