Project

General

Profile

Unable to import contacts to "Contacts" app

Added by Patrick Lendi 5 months ago

Goal:
Transfer all contacts from my old iPhone to my new Replicant-powered phone.

I have so far:
- Transferred all contacts to Windows 7 using iTunes.
- Converted the contact files from the Windows-specific ".contact" format to the vCard format (".vcf"), using a built-in tool from the Windows file explorer.
- Merged the individual .vcf files to a single file called "all-contacts.vcf", using cat on Trisquel GNU/Linux.
- Copied the file to the "Download" folder on my phone ("/storage/emulated/0/Download") over USB.

Where I'm stuck:
I've tried to import the .vcf file to the "Contacts" app on Replicant (Menu → Import/Export → Import from .vcf file → Local phone account), but when I select "Open from → Downloads", it says "No items". It appears to me as if the app doesn't have permissions to read that directory. I made sure that Privacy Guard was disabled for the app, but that didn't help.
What I find strange is that "Downloads" is the only directory to choose from, but maybe that's intentional.

Does anybody have an idea what I might be doing wrong?


Replies (3)

RE: Unable to import contacts to "Contacts" app - Added by Kurtis Hanna 5 months ago

When I click on Menu → Import/Export → Import from .vcf file → Local phone account it then opens up "Internal Storage" where I can open up any file located anywhere, including the contacts.vcf file in my root directory on my internal storage. I'm honestly not sure what the issue is that you're having, but maybe you should open up the File Manager app to see if you can find your all-contacts.vcf file with it. Maybe the File Manager app is being used by Contacts but you haven't given File Manager the correct permissions yet because you haven't opened the app yet.

RE: Unable to import contacts to "Contacts" app - Added by Patrick Lendi 4 months ago

Hi Kurtis, thanks for the quick reply.

I can confirm that my all-contacts.vcf file is in the directory I have stated. In fact, because I'm unfamiliar with Android's directory structure, I had to look up what directory the Download folder corresponds to (i.e. starting from root) in the first place. Which means I've also used the File Manager app, and gave it root access.

It looks like you and I see different things after tapping "Local phone account". The "Internal Storage" page never shows up on my device.

Some additional info, for the sake of completeness:
- The version installed is Replicant 6.0
- Regarding Contacts:
A messenger app I've installed synchronized some contacts already over the app-specific Account.
- Regarding my storage:
I have added an SD card to my device, using it in the "internal storage" configuration.

RE: Unable to import contacts to "Contacts" app - Added by Patrick Lendi 4 months ago

I could resolve the problem finally.

It turns out that in the page "Open from", when the option "Hide SD card" is set (in the hamburger/three-dotted menu), the internal storage gets hidden as well! On top of that, this setting is apparently the default.

Before finding the solution, I reformatted the SD card as portable storage, and also performed a factory data reset. This changed nothing on the initial condition though (any storage was still hidden by default).

    (1-3/3)