Need root access to use SD card?

Added by Alexand(er|ra) Yst 6 months ago

Two to three months ago, I finally upgraded from Replicant 4.2 to Replicant 6.0. SInce then, I haven't been able to use my SD card. I've been trying to get it to read, and it just won't.

On Replicant 4.2, the device wouldn't read ext2 or ext3, but it read ext4, so that's how I had the SD card formatted. On Replicant 6.0, it's instead ext2 and ext4 that are claimed to be invalid formats. When I format as ext3 though, the device doesn't complain. That is, until I try to access the files in the file manager. I'm then informed that I need root access to access the SD card. The media manager is also unable to find the music files I keep on the card, showing that it's not just the file manager that can't access the card, and I can't reach the card over MTP, either. I've tried taking the card out, putting it in my laptop, and chmodding it to allow all users access to the card, but the mobile doesn't seem to care about that, and still insists I need root access to deal with the card.

Without proper character support in filenames, the SD card is of absolutely no value to me, so allowing the device to format it as whatever it wants to format it as (exFAT, I think?) won't work for me, though in my experiments, when I allowed it to do that, it did make the card readable. If it matters, this device is the GT-i9100.

Is there some way to get the SD card to read in Replicant 6.0 when formatted using a Linux filesystem, or do I need to downgrade to Replicant 4.2 just to use my SD card?

Replies (7)

RE: Need root access to use SD card? - Added by Kurtis Hanna 6 months ago

This topic has been discussed over here recently:

It sounded like it was resolved when the verbatim branded SD Card was replaced with a different brand of SD Card, but just today it was said that maybe that solution wasn't the end of the troubles. Any chance you have any other SD Cards available that you could use to test out whether they work?

RE: Need root access to use SD card? - Added by Alexand(er|ra) Yst 6 months ago

I just now tried with a SanDisk card, a PNY card, and two unbranded cards that appeared to be from different companies based on the text on them. I formatted all four cards as ext4, and the i9100 claimed they were all corrupted. I formatted all four cards as ext3, and the i9100 claimed I needed root permission to access the filesystem. Also of note, I put the file manager into root access mode, and the device still wouldn't read the ext3 cards, and claimed I needed root access, even though I already had root access.

Also, it looks like the issue you linked to is an entirely different issue. The issue you linked to is in regards to the device crashing when it tried to format cards. My device formats cards just fine (though it puts them in an unusable format, probably exFAT), but the device can't read SD cards that are formatted in reasonable (ext2, ext3, ext4) formats.

RE: Need root access to use SD card? - Added by Kurtis Hanna 6 months ago

Thanks for doing those tests and reporting back! I'll try to replicate this issue locally in the near future to see if I can figure out what is going on.

RE: Need root access to use SD card? - Added by Alexand(er|ra) Yst 6 months ago

I think I might have partly found the problem. After downgrading to Replicant 4.2, the device is seeing the internal storage differently. It sees two internal storage partitions, one of which it's calling "sdcard1", and the SD card isn't getting recognised no matter what it's formatted as. And "sdcard1" is unreadable; only the much smaller "sdcard0" can be read from and written to. Maybe with the second internal storage partition, the device has nowhere to mount the external SD card?

On second thought, that doesn't make any sense. Replicant 6.0 was able to mount an exFAT SD card, just not an SD card with a decent filesystem such as ext3 or ext4. I probably just broke something during the downgrade and made the device worse. I really wish these things were like desktops and laptops, where you could just wipe the drive entirely and install a fresh system on a fresh partition. I'm going to need to do some research and figure out how to fix Android partition layouts and hope I don't mess up the baseband partition in the process. Then I'd really be out of luck.

RE: Need root access to use SD card? - Added by Kurtis Hanna 6 months ago

Can you try out this solution on Replicant 6 and let us know if it works?

If it works well we should add it to our wiki.

RE: Need root access to use SD card? - Added by Kurtis Hanna 6 months ago

Sorry, you said that exFAT is unusable. What do you mean by that? You did say you want to use ext2, ext3, or ext4, so maybe this isn't a proper solution for you.

RE: Need root access to use SD card? - Added by Alexand(er|ra) Yst 6 months ago

As stated in the initial post, exFAT was working fine for SD cards on Replicant 6.0, though now that I've messed the system up worse, I'm not sure if any SD cards will work on this device. However, exFAT's lack of character support in file names means that I can't transfer my music collection to an exFAT SD card without going through and renaming a huge chunk of my files by hand, which would be a major pain in the rear, and not worth it. Again, I need a filesystem with decent character support, which would include systems such as ext2, ext3, and ext4. Before I upgraded from Replicant 4.2 to Replicant 6.0, Replicant 4.2 was using an ext4 SD card without any problems. After the upgrade, Replicant 6.0 refused to read anything besides the crippled filesystem, exFAT. And now after the downgrade, my partition table is messed up and the device isn't recognizing SD cards at all, which may or may not be two unrelated issues. Either way, if I were to get exFAT working, it woulnd't be a step forward, but would instead put me back in the state I discussed in the initial post. I'd be back as square zero.