Galaxy Nexus I9250 Not Booting

Added by Anony Mous almost 5 years ago


This is the same person who made this thread (, and then solved it within minutes. Replicant is installed on my device now, but when I power it on, it gets stuck on the splash screen (where it shows the Replicant name and logo). The first time, I waited about 5 minutes for it to proceed, then turned it off. Now, I've been waiting about three hours at the same screen for it to keep going, but nothing is happening. Can anyone help me with my problem?

Replies (9)

RE: Galaxy Nexus I9250 Not Booting - Added by Andrés D almost 5 years ago

Hi Anony Mous.

Thanks for reporting. Did you wiped data when installing Replicant?

Your device is probably one of the less used with Replicant, so we don't have as much feedback as with i9100, i9300 or n7100. I have been building development roms for testing the changes in the future Replicant 6 revision, but I have not received feedback from maguro users (probably nobody has installed them). Could you try installing my builds making sure to wipe data (the content of the data partition will be lost)?

RE: Galaxy Nexus I9250 Not Booting - Added by Anony Mous almost 5 years ago

Hello Andrés,

I did indeed wipe my phone's data when installing for the first time.

I installed your builds (both and the maguro recovery image provided on your link). I followed the instructions on the RecoveryInstallationWithHeimdall page, followed by the Installation page exactly. I chose to install rather than upgrade the recovery image (meaning I ran heimdall flash --boot recovery-maguro.img --recovery recovery-maguro.img), since I didn't have a working Replicant installation. The only other deviation from the Wiki page was that I installed your Replicant build via adb sideload, as mentioned in this thread ( Everything else was done exactly as described in the Wiki.

Unfortunately, the result is the same: when booting, the device hangs on the splash screen page. It's been about eight minutes since I booted it up, and it is still on the splash screen (I assume it does not usually take that long). If there's any way I can give you more information, let me know.

RE: Galaxy Nexus I9250 Not Booting - Added by Gena Cheburashka over 4 years ago

I had the same problem as the OP. Recently learned about Replicant and my mom still had the Galaxy Nexus I gave her years ago. It still had an old Cyanogenmod installed.

What I did was immediately install the recovery for version 6 only to find out that I should have copied the .zip for the OS to the phone first. Since I couldn't connect to my PC I used sideload. This seemed to work fine, installed OK and just like the OP I followed all the steps, except for the sideload part. Even repeated the proces 2 more times with the same results.

So I started checking out the posts on this forum and someone said that they got it to install fine after a recent version of LineageOS.

So here's what I did:

1. Installed replicant 4.2 using the recovery and image found here:
2. Copied Lineage OS 14.1 (see step 4) and Replicant 6 to the phone via PC.
3. Installed TWRP 3.3.0 (3.3.1 gave an error while flashing) found here:
4. Installed Lineage OS 14.1 via TWRP found here:
5. Installed replicant 6 using the replicant 6 recovery (flashed with heimdall) and the .zip file from phone storage instead of sideload.
6. It worked! (yay!)

Now I'm not sure what made it work. Perhaps it was installing from the storage on the phone or something that Lineage OS 14.1 did. You could try skipping steps 3 & 4 and see if that works. As for the Lineage OS 14.1 please use at your own discretion. I'm not sure this is a good and safe image, but I figured I'd take the risk since the phone would be worthless to me otherwise. If you don't like the idea of using that perhaps find another Lineage OS image or at least try skipping step 3 and 4.

Hope you can get it to work!

RE: Galaxy Nexus I9250 Not Booting - Added by Gena Cheburashka over 4 years ago

Short addition to the post above.

I've now had some time to use the ROM a bit. The whole experience is a bit (too) laggy for my taste. It feels like I'm running software that's too heavy for the hardware. I guess perhaps this is just the effect of all the open source firmware/drivers/etc (I'm not very technical so my apologies if this doesn't make sense).

The camera doesn't work for me, I get a pop-up that says: Camera error, can't connect to camera.

I received a call earlier, but the sound was very choppy. The person on the other end couldn't hear me. He called me another two times, but had to use another phone to call him and actually speak with him.

Just thought I'd share this so that the OP knows what he can expect for any additional effort he puts in. Of course the problems may be on my end for other reasons, but wanted to share nevertheless.

RE: Galaxy Nexus I9250 Not Booting - Added by Anony Mous over 4 years ago

Thank you Gena; your method worked for me. I first tried installing Replicant 4.2, copying the Replicant 6 image onto the phone from there, then installing Replicant 6, but that yielded the same result of the phone hanging on the startup screen. So, it seems that Lineage OS 14.1 did actually do something to make Replicant boot properly. I'm glad that I finally have Replicant 6 working, although I haven't tried out using it for phonecalls yet, so I'll report back on that later. I do know that Replicant 6 doesn't support the Galaxy Nexus's camera.

I'll update the issue on the bug tracker, to let them know about your method of installing Lineage OS first, to make Replicant work. It is good that we have a method to make Replicant 6 work on the Nexus, but ideally it should work without having to install Lineage OS first.

RE: Galaxy Nexus I9250 Not Booting - Added by Kurtis Hanna over 4 years ago

Hello Gena Cheburashka,

Thanks for providing that guide and your feedback. Yes, the i9250 has one of the lowest CPU speeds and lowest amount of RAM out of the devices we support in Replicant 6. Likely the main reason for the lag is the fact that we use hardware acceleration for the graphics since we can't use the non-free components in the GPU. Regarding the Camera, it looks like we don't have support for it: I don't anticipate that anyone will be working to add support for the camera moving forward, but I could be mistaken. The issue you had with the phone call sounding choppy might be related to #1773. You might want to switch over to 2G instead of 3G when making a call to see if that solves the problem for you.


RE: Galaxy Nexus I9250 Not Booting - Added by eganonoa eganonoa almost 4 years ago


Figured on resurrecting this thread instead of starting a new one. Am new today to Replicant, using the Galaxy Nexus and experienced exactly the same thing as the other posters, fixed also by Gena's excellent guide. I had a couple of follow-on things;

1. Updating the Guide: It would be great if a link to this thread could be added to the installation instructions for this device. I spent hours fiddling around and searching until I landed here, including searches through the forum itself. Adding that link would be really helpful. And just to say, the step on Replicant 4.2 is not necessary. I went straight: TWRP > Lineage > Replicant 6.03.

2. Replicant 6.04: I cannot, however, get the latest release 6.04 to install. There is an image up, but no matter what I try I end up with it getting stuck on a blank screen after the google logo. Has anyone been able to get it to work? Sounds like there were some important changes made in this update, fixing serious security holes. Would be amazing to get it working.

Thanks everyone for all their work on this. The phone will be a nice compliment to my libreboot system, even if it isn't quite at that level of freedom. Pleased to have dug it out after some lockdown cleaning!

RE: Galaxy Nexus I9250 Not Booting - Added by Kurtis Hanna almost 4 years ago

Sorry, this 6.0 0004 rc1 bug is known and has recently been patched and the issue has been resolved.

We hopefully will be releasing an rc2 shortly with this fix included.