Project

General

Profile

Disabling system apps are not working

Added by John Newtral 5 months ago

Hi!

I'm trying to disable some system apps. However, when I reboot they are enabled again; all of them.

BTW, I'm not using any program for this.

My device is a Note 2 with rc3:
https://ftp-osl.osuosl.org/pub/replicant/images/replicant-6.0/0004-rc3/images/


Replies (4)

RE: Disabling system apps are not working - Added by Kurtis Hanna 5 months ago

Hello John,

Thanks for your message. While I am not sure that we have explicit documentation for this use case, I believe that you should be able to adopt the directions at this link in order to achieve your goal: https://redmine.replicant.us/boards/9/topics/14079?r=15389#Installation-Troubleshooting

In short, I believe that you will need to connect to your Note 2 using adb from a separate computer and then delete the apps you are trying to disable in /system/app/ or maybe also in /system/priv-app/ in order to disable them in a manner that ensures they won't be enabled again after a reboot.

Please let me know if you have any questions and if this is helpful.

Cordially,
Kurtis

RE: Disabling system apps are not working - Added by John Newtral 5 months ago

That seems to work. Thanks!

I was also disabling using adb and App Manager from F-Droid but didn't work either.

It could be interesting if we could disable apps easily in order to reduce RAM and CPU usage.

Anyway, thanks again for the workaround.

See you!

RE: Disabling system apps are not working - Added by Kurtis Hanna 5 months ago

Great! Happy to hear that this helped. You're very welcome. :-)

RE: Disabling system apps are not working - Added by John Newtral 19 days ago

BTW, using the local terminal, enabling it in developer options, works too.

These are the steps:
su
mount -o remount,rw /system
rm /system/app/appwewant.apk or rm /system/priv-app/appwewant.apk
reboot (due to mount -o ro,remount /system shows error. Anyway, it also works without that command)

Greetings.

    (1-4/4)