Project

General

Profile

error while pushing a directory but works with a file

Added by Fil Lupin 26 days ago

Hello,
I just installed a just built replicant 6.0004.

I noticed that when I push some directory on sdcard, I got this error:

adb push ./Conversations /storage/emulated/0/
adb: error: failed to copy './Conversations/Backup/aaa@bbb.ccc.ceb' to '/storage/emulated/0/Conversations/Backup/aaa@bbb.ccc.ceb': remote No such file or directory

However, when I copy a file from the same origin directory to the same destination directory, it works:

adb push 00001.vcf /storage/emulated/0/
00001.vcf: 1 file pushed. 2.1 MB/s (XXXX bytes in 0.462s)

As a workaround, I can manually create the file hierarchy and manually copy the files into the right directories.

I saw a similar issue could be solved by remounting sdcard with rw and chmod 777, but:
1. I do not have a problem with pushing a file to the same partition
2. it does not work
3. this workaround should not be necessary

I also noticed that there are some spaces in every directory names I tried to push.

Do you have any idea of how to solve this?