Project

General

Profile

Actions

Issue #1131

closed

Bizare SIM card

Added by Richard "Cylus" Palmer almost 8 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Telephony and mobile data
Target version:
Start date:
12/19/2014
Due date:
% Done:

0%

Estimated time:
Resolution:
wontfix
Device:
Galaxy S 3 (I9300)
Grant:
Type of work:

Description

As requested by Paulk, here is a bug report on my bizarre SIM card, which may or may not be related to a bug in Replicant.

When using this SIM card, the device claims to have no service in any spot in the interface where the carrier would normally be listed, such as at the bottom of the notification drawer or on the quick settings menu's mobile data square.

Actual service does not seem to be effected by this, and the signal strength icon functions as normal, showing both the strength of the signal and which network (E, 3G, H, H+) the device is connected to.

I'm not sure if it is related or not, but the SIM also does not seem to have access point information, so this information has to be entered into Replicant manually. This information might legitimately be missing from the SIM card, but it might just be unreadable by Replicant due to the same potential bug that is making the device claim not to have service.

I'm not sure what I'm looking for in the radio buffer, or even what to try to trigger while capturing said buffer, but I've uploaded some output. If you have any requests of what to try to trigger, I'd be happy to upload something specific.


Files

radiobuffer.txt (491 KB) radiobuffer.txt radio buffer Richard "Cylus" Palmer, 12/19/2014 04:15 AM
main.txt (342 KB) main.txt Richard "Cylus" Palmer, 01/16/2015 02:27 AM
radio.txt (290 KB) radio.txt Richard "Cylus" Palmer, 01/16/2015 02:27 AM
Actions

Also available in: Atom PDF