Project

General

Profile

Actions

Issue #1161

closed

4.2 0003 i9300 No cellular signal or mobile data

Added by Ted Smith almost 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
High
Category:
Telephony and mobile data
Target version:
Start date:
01/03/2015
Due date:
% Done:

0%

Estimated time:
Resolution:
worksforme
Device:
Galaxy S 3 (I9300)
Grant:
Type of work:

Description

Everything seems to be working properly, but I have no mobile signal or data connection. I know that that the sim card works as I used it on this phone before installing Replicant. Tell me which log files you need and I'll provide them.


Files

replicantdebug (784 KB) replicantdebug The first log Ted Smith, 01/04/2015 11:58 PM
replicantdebug2 (786 KB) replicantdebug2 Second log. This one is slightly larger for some reason Ted Smith, 01/04/2015 11:58 PM
abdshelllog (1.18 KB) abdshelllog Ted Smith, 01/06/2015 01:10 AM
replicantlog2 (632 KB) replicantlog2 $ adb logcat -b radio - Radio buffer log Ted Smith, 01/07/2015 09:04 PM
efs2 (1.18 KB) efs2 $ adb shell "ls -la /efs" - In case you need it Ted Smith, 01/07/2015 09:04 PM
replicantdebug3 (28.6 KB) replicantdebug3 Ted Smith, 01/21/2015 08:23 PM
efs3 (1.18 KB) efs3 Ted Smith, 01/21/2015 08:23 PM
Actions #1

Updated by Ted Smith almost 8 years ago

I'll also add that the device won't mount on a computer:

Error: No such interface 'org.gtk.vfs.Mount' on object at path /org/gtk/vfs/mount/1
Please select another viewer and try again.

Actions #2

Updated by Paul Kocialkowski almost 8 years ago

The mount issue is probably because you don't have software to handle MTP. Recent versions of Debian/Trisquel/Ubuntu have that available.

Please provide logs of the radio buffer for the mobile data issue: GettingLogs.

Actions #3

Updated by Ted Smith almost 8 years ago

I got the MTP issue figured out.

aLogcat:

For the logs, I tried to use the aLogcat method, but my sdcard is broken so it won't work till I get a new one.

adb logcat -b:

I used the command both on my host computer and the phone. The command executed and I got a "waiting for device" prompt. It stops there.

Actions #4

Updated by Paul Kocialkowski almost 8 years ago

Make sure you started adb with sufficient rights: usually, the server has to be started as root: sudo adb kill-server && sudo adb start-server before you can access the device. Then, you have to confirm the connection on the device. Eventually, you should be able to see the log with adb logcat -b radio.

Actions #5

Updated by Ted Smith almost 8 years ago

I have attached a log using the directions you outlined. I executed the command a second time and it produced a slightly larger log file. I'm not sure why.

Actions #6

Updated by Paul Kocialkowski almost 8 years ago

Actually, the modem is not working at all, so this is really not specific to mobile data. Upon startup, the modem asks the RIL to write some data to nv_data, which is not unusual and for some reason, the RIL cannot do it correctly, reports the error to the modem, which puts itself in a failure state. Once that is detected, the RIL starts it up again, only to receive the same message and fail again, so this goes in a failure loop that goes on and on.

So we need to figure out why this fails. Can you run the following:

adb root
adb shell "ls -la /efs" 

Also, did you temper with the efs partition in any way?

Actions #7

Updated by Ted Smith almost 8 years ago

Here's the log. The efs partition has not been altered. I also installed cyanogenmod and had the same problem.

Actions #8

Updated by Paul Kocialkowski almost 8 years ago

The rights of those files are not correct. You can fix them by running:

adb root
adb shell chown radio:radio /efs/nv_data.bin
adb shell chown radio:radio /efs/nv_data.bin.md5
adb shell chown radio:radio /efs/nv.log
adb shell chown radio:radio /efs/.nv_data.bak.md5
adb shell chown radio:radio /efs/.nv_core.bak.md5
adb shell chown radio:radio /efs/.nv_core.bak
adb shell chown radio:radio /efs/.nv_state
adb shell chown radio:radio /efs/h2k.dat
adb shell chown system:system /efs/gyro_cal_data
adb shell chown radio:radio /efs/wv.keys

Then reboot the device and it should work. Note that this was specific to your device, nothing related to a bug in Replicant.

Actions #9

Updated by Paul Kocialkowski almost 8 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme
Actions #10

Updated by Ted Smith almost 8 years ago

This fixed the cellular issue but not the mobile data issue.

Actions #11

Updated by Paul Kocialkowski almost 8 years ago

  • Status changed from Closed to In Progress
  • Resolution deleted (worksforme)

Please provide logs (radio buffer) again so that we can investigate what is going on.

Actions #12

Updated by Ted Smith almost 8 years ago

Actions #13

Updated by Paul Kocialkowski almost 8 years ago

Everything seems to be working fine. The log doesn't show that you enabled mobile data, so please submit a lot where you actually enable it (e.g. in the Settings application). If not enabled, mobile data is obviously not going to work.

Actions #14

Updated by Ted Smith almost 8 years ago

It's working now. Thanks for all your hard work, Paul.

Actions #15

Updated by Ted Smith almost 8 years ago

Ted Smith wrote:

It's working now. Thanks for all your hard work Paul.

Actions #16

Updated by Ted Smith almost 8 years ago

Ted Smith wrote:
It's working now. Thanks for all your hard work Paul.

Actions #17

Updated by Paul Kocialkowski almost 8 years ago

  • Status changed from In Progress to Closed
  • Resolution set to worksforme

Great!

Actions #18

Updated by Ted Smith almost 8 years ago

The problem is back again. I attached logs.

I did this:
adb root
adb shell chown radio:radio /efs/nv_data.bin
adb shell chown radio:radio /efs/nv_data.bin.md5
adb shell chown radio:radio /efs/nv.log
adb shell chown radio:radio /efs/.nv_data.bak.md5
adb shell chown radio:radio /efs/.nv_core.bak.md5
adb shell chown radio:radio /efs/.nv_core.bak
adb shell chown radio:radio /efs/.nv_state
adb shell chown radio:radio /efs/h2k.dat
adb shell chown system:system /efs/gyro_cal_data
adb shell chown radio:radio /efs/wv.keys

Then sudo adb logcat -b radio > replicantdebug3

Then adb shell "ls -la /efs" > efs3

Actions #19

Updated by Paul Kocialkowski almost 8 years ago

This is unrelated, please open a new ticket if the issue is still there, but mostly, D/RIL-IPC ( 1900): Reading EBL ACK failed indicates an error from the modem-side that cannot be solved by Replicant and is likely to be the same with e.g. CyanogenMod. I suggest you reboot your device or take the battery out for 10 minutes to let everything cool down.

Actions #20

Updated by Denis 'GNUtoo' Carikli almost 7 years ago

  • Category changed from 117 to Telephony and mobile data
  • Device Galaxy S 3 (I9300) added
Actions

Also available in: Atom PDF