Project

General

Profile

Issue #1173

Cellular connection stops and wants PIN code again

Added by Flo Debian over 6 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
High
Category:
Telephony and mobile data
Target version:
Start date:
01/08/2015
Due date:
% Done:

0%

Estimated time:
Resolution:
wontfix
Device:
Galaxy S (I9000)
Grant:
Type of work:

Description

I have installed 4.2 0003 and I applied the fix (bug 1137).

After some time (a few hours or sometimes not even one hour) the cellular connection stops. This may happen while I don't do anything (the screen is dark) (then I don't recognize that it lost connection unless I start to use it again) or while being active (happened two times when I am on a call).

Then it indicates that there is no reception an most of the times I am requested to reenter my SIM card PIN and most of the times it's working again afterwards.

Please tell me which log and at which time I should provide.

Thank you.


Files

crash-radio.txt (292 KB) crash-radio.txt Flo Debian, 01/22/2015 04:14 PM
crash-main.txt (226 KB) crash-main.txt Flo Debian, 01/22/2015 04:14 PM
#1

Updated by Paul Kocialkowski over 6 years ago

Sadly, it looks like the modem crashing, which happens, even with the proprietary RIL. The way they work around it is by storing the PIN somewhat encrypted and unlocking the SIM after it reboots, so that it's almost transparent to the user.

That's really a problem from the modem side, nothing we can do about it except handle the crash better. If it comes back to the PIN dialog, it already means that recovery from the crash worked, which is already something!

I will look into storing the PIN in a similar fashion so that it becomes more transparent and doesn't make you miss calls or messages.

Please tell me which log and at which time I should provide.

The best thing to do is to not enter your PIN, connect the device to a computer and grab logs. This way you can make sure that the crash is there. Please include both the radio and main buffers.

That was I can confirm this is what I'm talking about, but there is no real fix for that behaviour.

#2

Updated by Flo Debian over 6 years ago

Thank you for looking into it.

It happenend that I got an S2 as a friend changed to an S5.
The S2 seems to be more stable (it only happened two times the last 5 days). So for me it's not that urgent anymore. I steped back to 4.2 0002 which doesn't have that issue and is good enough as backup device.

Nevertheless I will provide the log files. Since I am out of town for a couple of days more I can't do that before end of next week.

Regards.

#3

Updated by Paul Kocialkowski over 6 years ago

The Galaxy S 2 (I9100) should indeed be more stable on this regard.

I steped back to 4.2 0002 which doesn't have that issue and is good enough as backup device.

That's very odd, there should be no regression between 4.2 0002 and 4.2 0003 (well, as you know, I still can make mistakes). If it worked better with 0002, then it may not be modem-related, in which case the logs will be even more important.

#4

Updated by Flo Debian over 6 years ago

I restored 4.2 0003, booted the device and soon (after about 45min) it asked me for the PIN again.

I plugged the phone to the computer and entered:

adb logcat -b radio > crash-radio.txt
adb logcat -b main > crash-main.txt

I hope I am providing the right logs.

#5

Updated by Flo Debian over 6 years ago

Right now my S2 showed the same problem as well, for the third time. This happens much less frequent than with the S. Unfortunately the permissions were not set correctly for debugging and I couldn't read the logs. I will do this next time (if a computer is available).

#6

Updated by Paul Kocialkowski over 6 years ago

This looks like an actual issue on our software implementation side, I will have to take a deeper look into it.

This is probably not the same problem on the other device, feel free to open a new ticket with logs from the S2!

#7

Updated by Denis 'GNUtoo' Carikli over 5 years ago

  • Device Galaxy S (I9000) added
#8

Updated by Denis 'GNUtoo' Carikli over 5 years ago

  • Category changed from 69 to Telephony and mobile data
#9

Updated by Kurtis Hanna almost 2 years ago

  • Resolution set to wontfix

This issue has been closed because Replicant 4.2 is no longer supported or maintained.

#10

Updated by Kurtis Hanna almost 2 years ago

  • Status changed from New to Closed

Also available in: Atom PDF