Project

General

Profile

Issue #1191

Sound Switches Off Below A Certain Volume on Samsung Galaxy S2 (GT-I9100)

Added by Robert Sanches over 6 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Framework
Target version:
Start date:
01/24/2015
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed
Device:
Galaxy S 2 (I9100)
Grant:
Type of work:

Description

As the subject says, the problem is, that if I reduce my volume below a certain level, my music starts to sound strange. What I mean by this is, that in the parts where the volume of the music itself drops below a certain level, the sound completely switches off.

How did I find out?
While I'm reading I like to listen to music with my headphones at a very low volume. I just want it to keep my mood up, but I don't want it as present that it distracts me from my lecture. While reading I somewhen noticed that my music was kind of skipping. First I thought that Apollo had a problem playing my MP3's (I suspected a caching issue). So is tried two other players (mort player / clean music) but the problem still occurred. So I switched off all DSP-Manager modifiers (they where not working on the other players anyway). But the problem was still there.

Does anyone know this problem? And furthermore, is there a fix for it (besides buying headphones with a volume control on its cable)?

Hopefully someone can help me.
I'm using the current Replicant 4.2 0003 on my Samsung Galaxy SII.

Cheers
Quirk

p.S. please excuse my bad English. I'm not a native speaker.

#1

Updated by Robert Sanches over 6 years ago

there are decision of problem: http://forum.cyanogenmod.org/topic/73718-sound-switches-off-below-a-certain-volume/page__st__20
we can see that this bug comes from CyanogenMod

#2

Updated by Denis 'GNUtoo' Carikli over 5 years ago

  • Category changed from 81 to Framework
  • Device Galaxy S 2 (I9100) added
#3

Updated by Wolfgang Wiedmeyer about 4 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

All cyanogenmod.org services are down, but the forum post was archived: https://web.archive.org/web/20150214074458/forum.cyanogenmod.org/topic/73718-sound-switches-off-below-a-certain-volume/page__st__20

It looks like this was fixed in CyanogenMod. I didn't try to find the patch, but I'd expect that the patch is included in Replicant 6.0 and thus, the bug shouldn't be present there. So I'm closing this as fixed.
Feel free to report back if this is not the case. Then I'll reopen this issue for Replicant 6.0.

Also available in: Atom PDF