Project

General

Profile

Actions

Issue #1197

closed

Cellular connection stops and wants PIN code again

Added by Flo Debian almost 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Telephony and mobile data
Target version:
Start date:
01/25/2015
Due date:
% Done:

0%

Estimated time:
Resolution:
wontfix
Device:
Galaxy S 2 (I9100)
Grant:
Type of work:

Description

Similar to issue 1173.

At some point the connection is lost and I am asked to enter the PIN Code. This happens once in something like three days.

Before entering the PIN I executed the following commands:

adb logcat -b main > crash-main_s2.txt
adb logcat -b radio > crash-radio_s2.txt

The device is running 4.2 0003


Files

crash-radio_s2.txt (900 KB) crash-radio_s2.txt Flo Debian, 01/25/2015 06:13 PM
crash-main_s2.txt (402 KB) crash-main_s2.txt Flo Debian, 01/25/2015 06:13 PM
dmesg_s2.txt (1.01 MB) dmesg_s2.txt Flo Debian, 01/29/2015 03:28 PM
Actions #1

Updated by Paul Kocialkowski almost 8 years ago

Remember that the symptoms are the same, but the issue is actually quite different. In that case, we can see:

E/RIL-IPC ( 1849): Polling IPC FMT client failed

Which indicates a modem-side problem. Running adb shell dmesg should provide kernel logs that reflect this situation. Feel free to grab some next time it happens and attach them here to confirm.
Ideally, Samsung-RIL should re-enter the PIN automatically so that this is transparent to the user, just like it is with the proprietary RIL (where those failures happen as well). In the meantime, you can simply disable the PIN code and it will get service back automatically.

In addition to that, Samsung-RIL does crash when flushing data, so this should be fixed. Perhaps a close/open cycle would have been enough to recovery from the issue. With the crash, a cold boot is triggered, leaving no chance of soft recovery.

Actions #2

Updated by Flo Debian almost 8 years ago

Here is

adb shell dmesg > dmesg_s2.txt

from the last crash.

Thank you for your help.

Actions #3

Updated by Denis 'GNUtoo' Carikli almost 7 years ago

  • Category changed from 81 to Telephony and mobile data
  • Device Galaxy S 2 (I9100) added
Actions #4

Updated by Kurtis Hanna over 3 years ago

  • Resolution set to wontfix

This issue has been closed because Replicant 4.2 is no longer supported or maintained.

Actions #5

Updated by Kurtis Hanna over 3 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF