Project

General

Profile

Actions

Issue #1329

closed

Recovery - Status 0 - Installation aborted

Added by Niels Heyvaert about 7 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Normal
Category:
Framework
Target version:
Start date:
09/09/2015
Due date:
% Done:

0%

Estimated time:
Resolution:
invalid
Device:
Galaxy S (I9000)
Grant:
Type of work:

Description

Dear forum,

I'm struggling to get Replicant installed on my Galaxy S.

Trying to go back to factory settings, my rooted phone got bricked. After struggling with the USB drivers via zadig I finally managed ODIN (very flaky tool !) to recognise the device. I managed to repartition the phone using the PIT file s1_odin_20100512.pit (from google code)

I then started took the Replicant recovery image and installed that image. It now states CWM-based recovery v6.0.4.6 and operates without errors when mounting unmounting etc.

Now, when in recovery mode and pushing (adb) the Replicant MOD I always get an error stating:

E:Error in storage sdcard0 update.zip
(status 0)
Installation aborted.

I've looked at various combinations, rebooting reconnecting, re-wiping, toggling signature verif, sideloading vs pushing, etc. etc.

So far I have not found a root cause or way to avoid the error and continue with the ROM installation.

Any idea what is causing the error message in the ROM zip files with Status 0 ?

After a fresh reboot in recovery and going to Advanced-show log, I can see:

I:Skipping execution of extendedcommand, file not found...
I:Cannot load volume misc
I:Can't partition non mmcblk device: devices platform s3c-sdhci.0 mmc_host mmc0

Thanks in advance for your feedback.

Actions #1

Updated by Paul Kocialkowski about 7 years ago

  • Status changed from New to Rejected
  • Resolution set to invalid

Now, when in recovery mode and pushing (adb) the Replicant MOD I always get an error stating:

Please call our system Replicant, not Replicant MOD or Replicant OS.

E:Error in storage sdcard0 update.zip

Looks like you're looking for update.zip, if you follow closely the Replicant installation instructions for your device, you'll see that you have to select the zip manually after pushing it to the device!

If not, make sure that the internal storage is formatted correctly or simply use an external microsd.

I:Can't partition non mmcblk device: devices platform s3c-sdhci.0 mmc_host mmc0

That looks slightly suspicious, but not something I would worry about at first.

Note that this belongs in a forum thread (Forums tab on redmine), not in a bug report, so I will close it at once.

Actions #2

Updated by Denis 'GNUtoo' Carikli almost 7 years ago

  • Category changed from 69 to Framework
  • Device Galaxy S (I9000) added
Actions

Also available in: Atom PDF