Project

General

Profile

Actions

Issue #1407

closed

Contact name problem when calling from phone log.

Added by Franco Masotti about 7 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Low
Category:
Base applications
Target version:
Start date:
10/31/2015
Due date:
% Done:

0%

Estimated time:
Resolution:
worksforme
Device:
Galaxy S 3 (I9300)
Grant:
Type of work:

Description

When selecting a person to call (who is present in the phone book) from the call log, "Unknown" and "-" is shown instead of the person's contact name and number respectively.
Bug is present on 4.2 003 and 4.2 004 on Samsung I9300.

Thank you.

Actions #1

Updated by Franco Masotti about 7 years ago

UPDATE
This bug presents itself not only from the phone log but also (sometimes) when I select the contact from the numeric keypad.

Actions #2

Updated by My Self almost 7 years ago

I fear I can't reproduce your issue, or just don't get what you mean exactly.

I've played around a bit and got the following call log:

Explanation:
  1. are several incoming (missed calls) and outgoing calls from/to a known contact (present in the phone book),
    the correct number is shown and could be called from the phone log properly.
  2. is an incoming call from a known landline contact (present in the phone book),
    but with withheld number (through the provider). Same would happen with withheld cell phone numbers.
  3. is an incoming call from an unknown contact (not present in the phone book),
    the correct number is shown and could be called from the phone log properly.
  4. are incoming (accepted calls) calls from another known contact (present in the phone book),
    the correct number is shown and could be called from the phone log properly.
  5. is an outgoing call to an unknown contact (not present in the phone book),
    the correct number is shown and could be called from the phone log properly.

I don't had such problems on my Samsung I9100, neither on 4.2 0003 nor on 4.2 0004.

But I have to say, that I don't manage my contacts (phone book) on my Replicant device. I create a vCard (v3.0, with all of my contacts) and import this to my Replicant contacts by simply open the resulting .vcf file with a file manager.
Because you could double-import your contacts that way, I [Clear data] from the system-app "Contacts Storage" before I import the vCard again, (on contact changes or something).
I can't say, if this is responsible for a better behavior on my device, but I thought I should say that fact.
By the way, if you create "BDAY" values, too, you could keep track of birthdays of your contacts with apps like:

Sorry that I can't help here, yet.

Actions #3

Updated by Paul Kocialkowski almost 7 years ago

I cannot duplicate the issue either. Also, please report this upstream if it is still present there (in either AOSP or CyanogenMod, it does not look specific to Replicant at all)..

Without more information, I'll close this ticket since it apparently works for everyone else.

Actions #4

Updated by Denis 'GNUtoo' Carikli almost 7 years ago

  • Category changed from 117 to Framework
  • Status changed from New to Feedback
  • Device Galaxy S 3 (I9300) added
Actions #5

Updated by Franco Masotti almost 7 years ago

Thanks for all your tips.
Yes, I wasn't clear enough. It's more similar to case 1: when the phone starts dialing a known contact (with name and number), from the phone log, the name gets changed to "Unknown". When the phone call ends, instead of showing name and number in the log, "Unkown" and "-" are shown. All of this happens ONLY for outgoing calls.

Anyway it's no big deal (that's why I have set this bug to the lowest priority when I first opened this thread). I'll try to remove cache and contacts and handle them in the way you suggested.

Thanks again.

Actions #6

Updated by Paul Kocialkowski almost 7 years ago

  • Category changed from Framework to Base applications
  • Status changed from Feedback to Rejected
  • Resolution set to worksforme
Actions

Also available in: Atom PDF