Feature #1479

GSD4t GPS support

Added by Denis 'GNUtoo' Carikli almost 5 years ago. Updated over 1 year ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:


It applies to the following devices:
  • Galaxy S2 (I9100)
  • Galaxy Nexus (I9250)

There was some attempt long time ago at GSD4t, however nowadays there seem to be a free software implementation of it already in gpsd (git://

Porting GPSD to android might be doable.


Updated by Denis 'GNUtoo' Carikli almost 5 years ago

  • Category set to 51
  • Target version set to Any version

Updated by Denis 'GNUtoo' Carikli almost 5 years ago

  • Category changed from 51 to Framework
  • Device Multiple devices added

Updated by Paul Kocialkowski over 4 years ago

  • Subject changed from Implement the GSD4t GPS protocol to GSD4t GPS support
  • Device added
  • Device deleted (Multiple devices)

Updated by Paul Kocialkowski over 4 years ago

  • Category changed from Framework to GPS

It's likely not the same protocol that was used. gpsd might support the GSD4e, which uses the SiRF One Socket Protocol (OSP), but the GSD4t seems to be using another protocol.


Updated by Matija Nalis over 4 years ago

big chunks of the GSD4t protocol have been decoded at
While something looking like GPS 50bps data have been extracted, it is still not enough to get a GPS fix.

Unfortunately, I've been unable to hack on it for some time, which probably won't improve as I'm not using that phone anymore.
So I'm documenting this in case somebody wants to take over and try to decode remaining bits)


Updated by Kurtis Hanna over 1 year ago

I haven't tried it yet, but it looks like someone has a tutorial here on how to install the Guix package manager on Replicant:

They have packaged

I don't see gpsd packaged

Perhaps someone could write the needed recipe for it and add it as a package to Guix so that we could install it on Replicant if gpsbabel won't work to solve the ticket.


Updated by Kurtis Hanna over 1 year ago

someone in termux upstream posted this:

"I can get the GPS data live stream out of android into termux with the app BlueNMEA, and sent that stream over cellular connection to my PC at home, with netcat.

I still have to find out how to push that data into gpsd programs. I am new in GPS programs.

Also there is this termux command "termux-location", it gives a one-shot current location data, so the device node is accessible (don't know whether I am root or not)."

Also available in: Atom PDF