Project

General

Profile

Issue #1605

SIM card not recognized GT-i9300 (modem crash)

Added by Alex V almost 3 years ago. Updated 4 months ago.

Status:
New
Priority:
High
Category:
Telephony and mobile data
Target version:
Start date:
01/25/2016
Due date:
% Done:

0%

Resolution:
Device:
Galaxy S 3 (I9300)

Description

I have installed Replicant 4.2 (0004) on my samsung galaxy S3 and unfortunately my SIM card is not recognized.
Following your Wiki, the installation was correctly done. In attachment, the radio log file.

Please can you help me?
Thanks in advance

radio_log_replicant_4.2_0004.txt View (48.9 KB) Alex V, 01/25/2016 02:14 PM

log_dmesg.txt View (130 KB) Alex V, 02/20/2016 09:30 AM

Replicant4.2-GTi9300-radio.log.gpg (25 KB) Nicolas Feudé, 04/10/2017 08:11 PM

Replicant4.2-GTi9300-radio-works_with_firmwares.log.gpg (35.2 KB) Nicolas Feudé, 04/10/2017 08:11 PM

Replicant4.2-GTi9300-radio-works_without_firmwares.log.gpg (35 KB) Nicolas Feudé, 04/10/2017 08:11 PM

Replicant6.0-GTi9300-radio.log.gpg (36 KB) Wolfgang Wiedmeyer, 05/26/2017 08:53 PM

replicant_events.log.gpg (5.75 KB) Alex V, 06/08/2017 07:20 PM

replicant_dmesg.log.gpg (30.3 KB) Alex V, 06/08/2017 07:20 PM

replicant_main.log.gpg (29.4 KB) Alex V, 06/08/2017 07:20 PM

replicant_radio.log.gpg (15 KB) Alex V, 06/08/2017 07:20 PM

replicant_system.log.gpg (12.7 KB) Alex V, 06/08/2017 07:20 PM

website.txt.gpg (1.73 KB) Alex V, 06/21/2017 06:06 PM

warning.txt.gpg (1.7 KB) Alex V, 06/22/2017 06:32 AM


Related issues

Related to Issue #1783: SIM card not recognized (regression, was working with Replicant 4.2) New 04/05/2017
Related to Issue #1809: No SIM card No service reported but sim present New 06/06/2017

History

#1 Updated by Alex V almost 3 years ago

My IMEI is unknown.
I have seen a similar problem on the forum (http://redmine.replicant.us/boards/9/topics/8841?r=9411#message-9411), but I can't solved my problem.

Please can you help me?
Thanks

#2 Updated by Paul Kocialkowski almost 3 years ago

Looks like the modem is crashing. Maybe kernel logs (dmesg) could help.

#3 Updated by Paul Kocialkowski almost 3 years ago

  • Category changed from Framework to Telephony and mobile data

#4 Updated by Alex V almost 3 years ago

Ok, please find in attachment in the request kernel log file.
Hope, it can help you.

#5 Updated by Fil Lupin over 2 years ago

I have a similar issue.
Do you have any idea of the issue there?

#6 Updated by Alex V over 2 years ago

Sorry but I don't have the solution.

#7 Updated by Alex V about 2 years ago

After long time, I finally find a solution for the sim card on the xda-developers.com forum. I have patched the modem.
Unfortunately, I don't think that is a open-source and free solution.
The smartphone have the capability to unlock sim card and to search a mobile signal but it display always "Emergency calls only".
That means, there is not a hardware problem but a software problem.
For information, I don't know if the modem use the international or European version.

Hope it can help you for future development and I wait your feedback.
Regards

#8 Updated by Nicolas Feudé over 1 year ago

I'm adding my own log from replicant 4.2, made in january. The SIM card is badly recognized. To be exact, it sometimes works randomly
It works with CyanogenMod 10.2, but i haven't made any log for it. Ask me if you want it.
I've done the log with and without the firmware (replicant 4.2), because the first time the simcard was recognized without the firmwares. It's not related and appears to be ramdomly recognized after a lot of test/reinstallation. I still put them in case it's useful.
The files are encrypted with Paul and Wolfgang keys

#9 Updated by Wolfgang Wiedmeyer over 1 year ago

  • File Replicant6.0-GTi9300-radio.log.gpg added
  • Subject changed from SIM card not recognized GT-i9300 to SIM card not recognized GT-i9300 (modem crash)
  • Target version changed from Replicant 4.2 to Replicant 6.0

Nicolas, this issue fits better than #1783. #1783 is actually about a regression between 4.2 and 6.0 where SIM cards are not recognized anymore (at all). With your phone, a similar if not the same crash happens as originally reported by Alex V in this issue here. So I changed the title of the issue and this issue should now track this kind of modem crash.

Could you also attach a dmesg with Replicant 6.0 that was captured after booting the device? It may contain a hint why the modem crashes. I attached the Replicant 6.0 log you originally attached to #1783.

#10 Updated by Wolfgang Wiedmeyer over 1 year ago

  • Priority changed from Normal to High

#11 Updated by Alex V over 1 year ago

I have upgraded to Replicant 6.0.
The sim card isn't recognized and the pin code isn't more asked.
I have read the log file. It seems that some files are missing on my S3 but I don't suppress anything.
The logs are in attachment. Hope it will help you.

#12 Updated by Wolfgang Wiedmeyer over 1 year ago

Alex V wrote:

I have read the log file. It seems that some files are missing on my S3 but I don't suppress anything.

A lot of these missing files errors are normal.
However, there is still an issue with the modem communication:

01-01 01:04:02.935  1965  2297 D use-Rlog/RLOG-RIL-IPC: Reading RFS data failed
01-01 01:04:02.935  1965  2297 E use-Rlog/RLOG-RIL-IPC: Receiving from IPC RFS client failed
01-01 01:04:02.935  1965  2297 E use-Rlog/RLOG-RIL: IPC RFS client loop failed
01-01 01:04:03.020  1965  2297 D use-Rlog/RLOG-RIL: Closed IPC RFS client

The modem is then initialized again.

#13 Updated by Alex V over 1 year ago

I don't understand, it's a little bit technical for me.
Sorry for that but what is the solution?

#14 Updated by Wolfgang Wiedmeyer over 1 year ago

Sorry, I don't know a solution at this point. Looking at the radio log revealed these errors that suggest that the modem crashes. Replicant fails to communicate with the modem pretty much right from the start. I'd be surprised if there is a difference between Replicant 4.2 and Replicant 6.0 as that part of the code didn't change.

#15 Updated by Alex V over 1 year ago

Ok, I have installed the Replicant 4.2 as described on your wiki and my S3 doesn't work.
But I have searched a solution for this problem and I have patched the modem with the menu of recovery 4.2
I have maybe done a mistake because I believe that is not an open-source solution.
In attachment, the website where I have founded the patch.
I appreciate your work and your help.
Thanks

#16 Updated by Alex V over 1 year ago

Sorry for my bad english.
The previous post is in the past, I can't use the past in english.

For information, during the installation I have a problem on 4.2 before the patch.
The warning is in attachment but I'm not sure of this message, it's maybe incorrect or incomplete.
I'm now on Replicant 6.0
It's all that I know.

Waiting your feedback
Thanks in advance

#17 Updated by robin p 10 months ago

Hi,
I'm having this problem too. I get the same radio messages (RLOG-RIL-IPC,Unknown,Booting IPC FMT client failed). The SIM works fine in Replicant 4.2 on my current S3, but not with Replicant 6.0.

On a previous (now broken) S3, the SIM worked fine with Replicant 6.0 r2

#18 Updated by Art Os 4 months ago

Hello,
I have similar issue on i9300 with firmware versions I9300BUUGNF1, I9300BVUGNB2, I9300XXUGMK6, I don't have tried others

I don't have this issue with I9300XXUGNA8 but issue #1773 (that why I have tried other modem firmware)

#19 Updated by Denis 'GNUtoo' Carikli 4 months ago

  • Category changed from Telephony and mobile data to SIM card not recognized

#20 Updated by Denis 'GNUtoo' Carikli 4 months ago

  • Category changed from SIM card not recognized to Telephony and mobile data

Also available in: Atom PDF