Project

General

Profile

Issue #1677

Cannot use the camera even if SD card is inserted

Added by Francesco Turco over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Camera
Target version:
Start date:
04/11/2016
Due date:
% Done:

0%

Estimated time:
Resolution:
worksforme
Device:
Galaxy S 2 (I9100)
Grant:
Type of work:

Description

I'm using Replicant 4.2 0004 with a Samsung Galaxy S2 I9100 phone. I can't use the camera anymore because I get the following error message:

Insert an SD card before using the camera.

I get this error both if I insert a microSD 32GB card and if I don't.

This is the second time I flash Replicant on my phone. When I first flashed it I didn't experience this error.

My knowledge of Android/Replicant/smartphones is still very limited. I may have made some mistake.

#1

Updated by Francesco Turco over 5 years ago

Replicant asked me to reformat the SD card, and I accepted. Now the problem is gone, and I can use the camera both with or without the SD card. What could have been the cause of the problem?

#2

Updated by Wolfgang Wiedmeyer over 4 years ago

Are you sure that Replicant asked you to reformat the external SD card? The S2 has an internal partition that is also named sdcard or sdcard0,

I suspect that there was an issue with the internal storage which made it inaccessible for the camera app, but there is not enough information to know what caused it.

As the issue seems to be resolved for you and as there are no logs to debug this, I think this issue can be closed.

#3

Updated by Wolfgang Wiedmeyer over 4 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

Also available in: Atom PDF