Project

General

Profile

Issue #1713

build error with I9300 and 4.2 0004

Added by Fil Lupin about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Category:
Build system
Target version:
Start date:
06/20/2016
Due date:
% Done:

0%

Estimated time:
Resolution:
Device:
Galaxy S 3 (I9300)
Grant:
Type of work:

Description

Hi, I tried yesterday to build replicant-4.2 on my xubuntu, but building failed with attached output.
Do you have any idea what's the problem?


Files

log_install_I9300.txt (3.08 MB) log_install_I9300.txt Fil Lupin, 06/20/2016 05:25 AM
#1

Updated by Fil Lupin about 5 years ago

After trying building a 4-core computer with 8Gb memory and 60Gb of harddisk, the behaviour is the same.
I will now try without the "-j" option to check if it changes anything.

Could someone say me how to get back to the 0003 version?
I remember I did not had any problem to build 0003, so at least, it could allow to build a replicant version waiting for a way to build the 0004.

I did not find any documentation for the repo tool.

#2

Updated by Fil Lupin about 5 years ago

Waiting for news, I made some investigations on my own.

The failure of building was due to available disk space.
This available disk space to install tools and source code and build is more than 60 Gib which but less than 100 Gib.
It is much more than the 40-50 Gib announced on the forum (http://redmine.replicant.us/boards/15/topics/6477). I already clarified this point on this subject.

Creation of some links (http://redmine.replicant.us/projects/replicant/wiki/BuildDependenciesInstallation) has perhaps solved a part of the issue.

Another correction should be done into "installing the image' part of http://redmine.replicant.us/projects/replicant/wiki/GalaxyS3I9300Installation :
the correct command to launch should be "sudo heimdall flash --BOOT boot.img --RECOVERY recovery.img --SYSTEM system.img --USERDATA userdata.img" more than "sudo heimdall flash --BOOT recovery.img --RECOVERY recovery.img".
The last one (which is actually the one given into the wiki page) creates an excessively slow system.

Then, once restarted the phone under CWM (v6.0.3.6) recovery mode, I printed the log. Here is the ourput:
----------
CWM-based Recovery v6.0.3.6
Warning: No file_contexts
dalvik.vm.stack-trace-file=/data/anr/traces.txt
init.svc.ueventd=running
init.svc.recovery=running
adb.recovery=1
init.svc.adbd=running
service.Adb.root=1

I:Checking for extendedcommand...
I:Skipping execution of extendedcommand, file not found...
I:Can't partition non-vfat: datamedia
I:Can't partition non-vfat: auto
I:Can't format unknown volume: /emmc
----------

I builded a new version of replicant because of another issue : http://redmine.replicant.us/boards/9/topics/13191
Perhaps is it linked...

#3

Updated by Fil Lupin about 5 years ago

The issue is solved (http://redmine.replicant.us/boards/9/topics/13191?r=13371#message-13371).
The installation with only BOOT and RECOVERY works the second time, I do not know what caused the slow effect.

#4

Updated by Loic Dachary almost 5 years ago

  • Status changed from New to Closed

Closing because the reporter claims the issue is resolved.

Also available in: Atom PDF