Project

General

Profile

Issue #1749

deleting a picture is impossible

Added by Fil Lupin about 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Base applications
Target version:
Start date:
08/23/2016
Due date:
% Done:

0%

Estimated time:
Resolution:
wontfix
Device:
Galaxy S 3 (I9300)
Grant:
Type of work:

Description

Hello,
I installed APhotoManager app as a manager for pictures on my I9000 Samsung galaxy S3.

Issue:
However, when deleting a picture, the thumbnail still appears into stuck gallery app even if it disappears from APhotoManager gallery. Then clicking on the thumbnail into stuck camera crashes the app.
Moreover, when starting stuck camera, it crashes, probably because last picture was deleted with APhotoManager.

Hypothesis 1:
My though is perhaps there is a database or a cache which has not been updated.
I cleared the cache and data from APhotoManager and stuck camera but this issue is still there.
I do not know where to search for others locations.

Hypothesis 2:
I noted that into APhotoManager app info, Enable Privacy Guard was enabled but it was disabled into stuck camera. I wonder if it can be the cause of this issue?
APhotoManager seems to have the good rights to delete a picture
Actually, rights of APhotoManager are :
- approximate location (network-based) and precise location (GPS and network-based)
- modify or delete the content of your SD card
- full network access, view network connections, view Wi-Fi connections
- test access to protected storage
Stuck camera has following rights:
- read your text messages(SMS or MMS), receive text messages (WAP)
- take pictures and vidos
- record audio
- precise location (GPS and network-based)
- modify or delete the content of your SD card
- full network access, view network connections
- run at startup
- prevent phone from sleeping
- set wallpaper
- interact across users, modify system settings, test access to protected storage
I though perhaps this is due to some rights issue...

Do you have any idea of how to solve this?
Thank you

#1

Updated by Fil Lupin about 5 years ago

I precise that I have installed a Replicant 4.2 0004 home-builded.

#2

Updated by Wolfgang Wiedmeyer over 4 years ago

Fil Lupin wrote:

I installed APhotoManager app as a manager for pictures on my I9000 Samsung galaxy S3.

The i9000 is the Galaxy S, not the S3. Is this bug report for the Galaxy S or S3?

Do you have the same issue with the gallery app that comes with Replicant? If this issue only happens with the APhotoManager app, then there's probably not much that can be done on the Replicant side, unless there is a known fix for it.

You might also want to report the issue to the APhotoManager devs if it only happens with their app.

#3

Updated by Wolfgang Wiedmeyer over 4 years ago

  • Category set to Base applications
  • Status changed from New to Feedback
  • Assignee set to Fil Lupin
#4

Updated by Wolfgang Wiedmeyer over 4 years ago

  • Target version set to Replicant 4.2
#5

Updated by Fil Lupin over 4 years ago

Thanks for your answer.

Wolfgang Wiedmeyer wrote:

The i9000 is the Galaxy S, not the S3. Is this bug report for the Galaxy S or S3?

My fault, you're right: my phone is a Galaxy S3 and not a i9000.

Wolfgang Wiedmeyer wrote:

Do you have the same issue with the gallery app that comes with Replicant? If this issue only happens with the APhotoManager app, then there's probably not much that can be done on the Replicant side, unless there is a known fix for it.

In fact, what I called stuck gallery app is the original gallery app installed by default.
My issue is with stuck gallery app, but APhotoManager works perfectly well.

#6

Updated by Wolfgang Wiedmeyer over 4 years ago

  • Device Galaxy S 3 (I9300) added
  • Device deleted (Galaxy S (I9000))
#7

Updated by Wolfgang Wiedmeyer over 4 years ago

Ok, Replicant 6.0 is available for the Galaxy S3. Please check if the issue is still there with Replicant 6.0.

#8

Updated by Fil Lupin over 4 years ago

Wolfgang Wiedmeyer wrote:

Ok, Replicant 6.0 is available for the Galaxy S3. Please check if the issue is still there with Replicant 6.0.

Thank you. I am trying to build a replicant-6, I will check as soon I finished.

For information, I opend a thread on this subject giving some details : https://redmine.replicant.us/boards/9/topics/13521

I see that this ticket is attributed to me, is it normal or is it an error?

#9

Updated by Kurtis Hanna about 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to wontfix

This issue has been closed because Replicant 4.2 is no longer supported or maintained.

Also available in: Atom PDF