Project

General

Profile

Actions

Issue #1761

closed

debian jessie build failure: unmappable character for encoding ASCII

Added by Loic Dachary about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Build system
Target version:
Start date:
10/22/2016
Due date:
% Done:

0%

Estimated time:
Resolution:
Device:
Grant:
Type of work:

Description

^[]0;[arm-sdk-eng] @8fb12095eb76: /opt/replicant-4.2^Groot@8fb12095eb76:/opt/replicant-4.2# make
build/core/main.mk:45: ********************************************************************************
build/core/main.mk:46: *  You are using version 4.0 of make.
build/core/main.mk:47: *  Android is tested to build with versions 3.81 and 3.82.
build/core/main.mk:48: *  see https://source.android.com/source/download.html
build/core/main.mk:49: ********************************************************************************
============================================
PLATFORM_VERSION_CODENAME=REL
PLATFORM_VERSION=4.2.2
CM_VERSION=
TARGET_PRODUCT=sdk
TARGET_BUILD_VARIANT=eng
TARGET_BUILD_TYPE=release
TARGET_BUILD_APPS=
TARGET_ARCH=arm
TARGET_ARCH_VARIANT=armv7-a
HOST_ARCH=x86
HOST_OS=linux
HOST_OS_EXTRA=Linux-4.4.0-45-generic-x86_64-with-debian-8.6
HOST_BUILD_TYPE=release
BUILD_ID=JDQ39E
OUT_DIR=/opt/replicant-4.2/out
============================================
external/bluetooth/bluedroid/Android.mk:8: NO BOARD_BLUETOOTH_BDROID_BUILDCFG_INCLUDE_DIR, using only generic configuration
build/core/tasks/kernel.mk:97: **********************************************************
build/core/tasks/kernel.mk:98: * Kernel source found, but no configuration was defined  *
build/core/tasks/kernel.mk:99: * Please add the TARGET_KERNEL_CONFIG variable to your   *
build/core/tasks/kernel.mk:100: * BoardConfig.mk file                                    *
build/core/tasks/kernel.mk:101: **********************************************************
Docs droiddoc: /opt/replicant-4.2/out/target/common/docs/doc-comment-check
/opt/replicant-4.2/out/target/common/obj/APPS/framework-res_intermediates/src/android/R.java:8660: error: unmappable character for encoding ASCII
                ALIGN_CENTER, or ALIGN_OPPOSITE, which are relative to each paragraph???s
                                                                                     ^
/opt/replicant-4.2/out/target/common/obj/APPS/framework-res_intermediates/src/android/R.java:8660: error: unmappable character for encoding ASCII
                ALIGN_CENTER, or ALIGN_OPPOSITE, which are relative to each paragraph???s
                                                                                      ^
/opt/replicant-4.2/out/target/common/obj/APPS/framework-res_intermediates/src/android/R.java:8660: error: unmappable character for encoding ASCII
                ALIGN_CENTER, or ALIGN_OPPOSITE, which are relative to each paragraph???s
                                                                                       ^
/opt/replicant-4.2/out/target/common/obj/APPS/framework-res_intermediates/src/android/R.java:8665: error: unmappable character for encoding ASCII
<tr><td>viewStart</td><td>5</td><td> Align to the start of the view, which is ALIGN_LEFT if the view???s resolved
^
Actions #1

Updated by Loic Dachary about 6 years ago

# locale                                                                                                                  
LANG=                                                                                                                                                                                                               
LANGUAGE=                                                                                                                                                                                                           
LC_CTYPE="POSIX"                                                                                                                                                                                                    
LC_NUMERIC="POSIX"                                                                                                                                                                                                  
LC_TIME="POSIX"                                                                                                                                                                                                     
LC_COLLATE="POSIX"                                                                                                                                                                                                  
LC_MONETARY="POSIX"                                                                                                                                                                                                 
LC_MESSAGES="POSIX"                                                                                                                                                                                                 
LC_PAPER="POSIX"                                                                                                                                                                                                    
LC_NAME="POSIX"                                                                                                                                                                                                     
LC_ADDRESS="POSIX"                                                                                                                                                                                                  
LC_TELEPHONE="POSIX"                                                                                                                                                                                                
LC_MEASUREMENT="POSIX"                                                                                                                                                                                              
LC_IDENTIFICATION="POSIX"                                                                                                                                                                                           
LC_ALL=

is the default after installing docker run --name replicant debian:jessie . The problem is fixed with

# dpkg-reconfigure locales
...
  65. bn_IN UTF-8                 144. en_US ISO-8859-1               223. fr_LU ISO-8859-1               302. lt_LT ISO-8859-13          381. se_NO UTF-8             460. zh_CN.GB18030 GB18030
  66. bo_CN UTF-8                 145. en_US.ISO-8859-15 ISO-8859-15  224. fr_LU.UTF-8 UTF-8              303. lt_LT.UTF-8 UTF-8          382. shs_CA UTF-8            461. zh_CN.GBK GBK
  67. bo_IN UTF-8                 146. en_US.UTF-8 UTF-8              225. fr_LU@euro ISO-8859-15         304. lv_LV ISO-8859-13          383. si_LK UTF-8             462. zh_CN.UTF-8 UTF-8
...
(Enter the items you want to select, separated by spaces.)

Locales to be generated: 144,146

Many packages in Debian use locales to display text in the correct language for the user. You can choose a default locale for the system from the generated locales.

This will select the default language for the entire system. If this system is a multi-user system where not all users are able to speak the default language, they will experience difficulties.

  1. None  2. C.UTF-8  3. en_US  4. en_US.UTF-8

Default locale for the system environment: 4

Generating locales (this might take a while)...
  en_US.ISO-8859-1... done
  en_US.UTF-8... done
Generation complete.
# export LANG=en_US.UTF-8

Actions #2

Updated by Loic Dachary about 6 years ago

apt-get install locales

before
dpkg-reconfigure locales

above.
Actions #3

Updated by Loic Dachary about 6 years ago

Part of the output makes it clear that it's a locale related problem:

Copying: /opt/replicant-4.2/out/target/common/obj/JAVA_LIBRARIES/content_intermediates/emma_out/lib/classes-jarjar.jar
Install: /opt/replicant-4.2/out/target/product/generic/system/framework/core-junit.odex
Install: /opt/replicant-4.2/out/target/product/generic/system/framework/core.jar
libcore/luni/src/main/java/java/util/Locale.java:435: error: unmappable character for encoding ASCII
     * <li>{@code new Locale("en", "US").getDisplayName(Locale.FRANCE)} -> {@code anglais (??tats-Unis)}
                                                                                           ^
libcore/luni/src/main/java/java/util/Locale.java:435: error: unmappable character for encoding ASCII
     * <li>{@code new Locale("en", "US").getDisplayName(Locale.FRANCE)} -> {@code anglais (??tats-Unis)}
                                                                                            ^
libcore/luni/src/main/java/java/util/Locale.java:436: error: unmappable character for encoding ASCII
     * <li>{@code new Locale("en", "US", "POSIX").getDisplayName(Locale.FRANCE)} -> {@code anglais (??tats-Unis,informatique)}.
                                                                                                    ^
libcore/luni/src/main/java/java/util/Locale.java:436: error: unmappable character for encoding ASCII
     * <li>{@code new Locale("en", "US", "POSIX").getDisplayName(Locale.FRANCE)} -> {@code anglais (??tats-Unis,informatique)}.
                                                                                                     ^
Copying: /opt/replicant-4.2/out/target/common/obj/JAVA_LIBRARIES/ime_intermediates/emma_out/lib/classes-jarjar.jar

Actions #4

Updated by Loic Dachary about 6 years ago

  • Status changed from New to Closed
  • Assignee changed from Paul Kocialkowski to Loic Dachary
Actions

Also available in: Atom PDF