Issue #1773


Metalic and horrible sound quality when call are made through 3G network / Replicant 4.2 & 6.0 on I9300 and N7100

Added by la belette over 7 years ago. Updated almost 3 years ago.

Telephony and mobile data
Target version:
Start date:
Due date:
% Done:


Estimated time:
Type of work:
C programming


Depending on who I am calling: the call is crystal clear or it is like metallic / robot and very difficult to listen correctly.
This is very reproducible as for some mobile numbers dialed it is or always crystal clear or always metallic.

My Replicant installation (4.2 or 6.0) is stock for everything expect Bluetooth (as I really need it), on Bluetooth it is working well every-time.
I confirmed it is not due to Bluetooth bloob as my 6.0 Replicant is without it.
I confirmed it is not a faulty hardware / speaker on my phone as going back to stock ROM is working well.

I had some discussion on IRC and someone advice me to temporarily disable 3G networks and force 2G and the problem gone.
It confirms that calls passing trough 3G have an issue, is there a way to disable this function somewhere in advanced settings? I need to keep 3G as 2G is too slow when I am using the phone for mobile data. (and switching to 2G is not an option when someone is calling me I don't have time to do it)


2G phone call.ogg (114 KB) 2G phone call.ogg Emmett Brown, 04/10/2021 07:16 PM
3G phone call.ogg (127 KB) 3G phone call.ogg Emmett Brown, 04/10/2021 07:16 PM
Actions #1

Updated by Laura Arjona Reina over 7 years ago

Hi, I'm experiencing the same issue in my Replicant 4.2.2 (same phone model, GT-i9300). I was going to try to update to 6.0 to see if the issue was gone, but now I'll stay in 4.2.2 since, if I did understand well, the issue is present in 6.0 too.

For me, switching to 2G is ok for now, because it happens only with one number and I usually call that number, not receive from it.

So, if you want me to do some test or attach a catlog just tell.

Actions #2

Updated by Wolfgang Wiedmeyer over 7 years ago

I'm not entirely sure if logs would help to solve the problem, but you could try the following:
Flash CyanogenMod and call a number where the sound issues happened. If the issue is also there with CyanogenMod, then there is maybe not much that can be done. But regardless if it works or not you can do the following:
  • Capture the radio log (see GettingLogs).
  • Flash Replicant again, do the same call and get the radio log
Actions #3

Updated by la belette over 7 years ago

For information, I move from my old mobile operator to another and the issue is gone.
Apparently I have heard that one (my old) is using as much as possible Voice over 3G but not my new one.
So this issus is temportaly solved for me, but will be a problem as soon as my new operator decides to use more the voice over data technology...

Actions #4

Updated by Wolfgang Wiedmeyer over 7 years ago

I could reproduce the issue when calling a LTE-enabled phone. I tested it with two i9300 phones which run Replicant 6.0. Only one of them had the issue. First, I thought the reason were different baseband firmwares on both phones, but this doesn't seem to be the case.
CyanogenMod doesn't have the issue, so the cause is likely somewhere in samsung-ril or the audio-ril-interface. I tried to figure out why one of the two Replicant phones worked and the other one didn't. In the end, I went back to stock rom on the phone that didn't work and called the LTE-enabled phone. After installing Replicant back, it suddenly worked.
My guess is that the stock rom changes settings on the operator side, in case that this is even possible. Strings in nv_data.bin didn't change, except for the build id which is expected. The SIM card worked with the i9300 phone that worked from the start, so changes to the SIM card are also unlikely.
As it works with CyanogenMod in any case, the goal should be to fix it in Replicant, but it would still be interesting to figure out what permanent change the stock rom did that made it work. Maybe Paul has an idea.

Actions #5

Updated by la belette over 7 years ago

Thanks for the update and your research.
It is very strange as I also have two i9300 and it was difficult to figure out the issue. The thing I discovered is that calling a particular number will always work or always failed (metalic sound).
For new Replicant adopter it could be a blocking point as it is a vital function which is not not working properly and this will be more and more common that SP activate voice over LTE.

Actions #6

Updated by noo bie over 7 years ago

I had the same issue with my galaxy s5 mini on an (unofficial) cm-13 / cm-14. The cause was that RIL_UNSOL_WB_AMR_STATE seems no longer to be supported and therefore low/wrong sampling rates were applied. Here's a link to the related commit Maybe this is related, I didn't check against the replicant RIL implementation.

Actions #7

Updated by Wolfgang Wiedmeyer about 7 years ago

  • Category set to Telephony and mobile data
  • Device Galaxy S 3 (I9300) added
  • Device deleted ()
Actions #8

Updated by Wolfgang Wiedmeyer about 7 years ago

  • Target version set to Any version
Actions #9

Updated by Wolfgang Wiedmeyer about 7 years ago

Yes, it very likely has something to do with setting the WB-AMR state. It needs to be different for Bluetooth So if it works with Bluetooth, but it doesn't work otherwise, then this is a strong indicator that the issue is because of that.

We don't have support for getting and setting this state in our Audio-RIL. This needs to be implemented.

Actions #10

Updated by Nichlas Severinsen over 6 years ago

Hi, this is also an issue for the Samsung Galaxy Note 2 7100 (with latest Replicant version 6.0 0002 as of 2017-09-21)

I've only tried these configurations:
Caller Setup + N2 Setup -> result
Unknown + Cellular data disabled -> horrible metallic robo sounds
Unknown + Cellular on & Preferred network: 2G -> normal sound
Unknown (probably not 3G) + Cellular on & Preferred network: 3G -> normal sound

Actions #11

Updated by Gu W over 6 years ago


I also noticed that on LineageOS some phone calls start with a similar horrible sound, but then after a short while it switches to proper sound quality. Also TWRP for i9300 seems to include some RIL code? ( ) Maybe this is related.
Anyway, the actual problem will probably be clear as soon as someone posts the radio log.

Actions #12

Updated by Kurtis Hanna over 6 years ago

Actions #13

Updated by Jérémie Libeau almost 6 years ago


I'm facing the same issue with my phone. Any update on that ?


Actions #14

Updated by Gu W almost 6 years ago

Kurtis Hanna wrote:

If anyone test out forkbomb's proposed fix to this and report back, that'd be great:

I am currently using the upstream Lineage version with the fix you proposed, but am still having the robot voice issue. However, for me it currently only happens when I get called.

Actions #15

Updated by Jan Prunk over 5 years ago


In my case on Samsung Galaxy S3 (GT-i9300) the incoming call appears as shaken, like frame-drop cut out voice, and at the same time the outgoing call is being frame-drop cut out aswell, the other side not hearing any voice temporary. It doesn't happen all the time, but only occasionally. At the location the signal is changing between 3G to 2G (E). I changed it now to use only 2G and will see if the problem re-appears.

Actions #16

Updated by Jacob Bahn about 5 years ago

Similar issue on an N7100 running Replicant 6.0 (version 0003).

Regarding sound I only use my mobiles for phone calls.
I get this terrible metallic sound when calling via 3G networks.
When using 2G the issue has not occurred yet, but it takes longer for the call to go through.
I replaced the speaker with no effect.

In the thread that Kurtis Hanna refers to, some users seem to have found solution by removing "the force_wideband hack".
Can somebody explain?
And is it possible to do on our replicant phones?

Actions #17

Updated by Anonymous about 5 years ago

I can confirm this issue on my recently acquired Galaxy Note 2 (N7100), running Replicant 6.0 0003.
This sound problem does not occur on my Galaxy S 2 (I9100) with Replicant 6.0 0003.
Also, this is not a hardware issue - stock Android worked fine before.

I tested a couple of conditions:
The problem occurs on 3G networks, on both incoming and outgoing calls, almost every time.
It is the same metallic sound with or without earbuds.
The microphone works fine in all situations.
Otherwise, the sound works well (when listening to music).

I tested disabling WB-AMR in the service menu (by dialing [*#*#197328640#*#*], then [5] AUDIO, [7] SETTINGS, [1] WB-AMR, [2] DISABLE) and did a factory reset after that.
However, the problem persists.

With LineageOS 14.1, the first call had the horrible sound as well. After that, the problem disappeared. So my guess is that this issue gets solved when Replicant reaches 9.0.
It is the same behaviour that Gu W had. However, for me on the N7100 the problem disappeared completely with Android 7.x.

Actions #18

Updated by Kurtis Hanna almost 5 years ago

Jacob Bahn: it looks like Replicant doesn't have the "force wideband" hack currently, so we can't revert it since we don't have it in our code currently.

Actions #19

Updated by Jacob Bahn almost 5 years ago

Niklas K, I wish to make a test installation of LineageOS on my N7100. Can you recommend where to download an image file and perhaps direct to installation instructions?

Actions #20

Updated by Kurtis Hanna almost 5 years ago

We will be supporting Replicant 9 on this device after Replicant 6. We plan on using LineageOS 16 upstream. If you'd like to try out an unofficial ROM of LineageOS you can find it here:

Here's the source code:

Here seems to be an install guide:

Here's where you can find the ROM of LineageOS 15:

All the other LineageOS ROMs I'm seeing are more than two years old, so I'm not going to link them here right now, but I can try to find them if you'd like.

It'd be great to know if LineageOS 16 has this bug or not.

Thanks for your willingness to help out with this Jacob!

Actions #21

Updated by Anonymous almost 5 years ago

Hello Jacob, I am now running LineageOS 14.1 from the XDA developers forum:
There is a link to the developers homepage:
I am running the ROM.

I do not have Gapps installed, because I am trying to avoid apps which depend on Google. Free Software only, if possible.

I have TWRP 3.3.0 installed from here:
There is now a 3.3.1 version, don't know if that works.

Flashing for me works best with heimdall instead of adb/fastboot. I followed the exact steps on Replicant's homepage:

Yes I know this ROM is outdated and possibly a security risk, but in my opinion it depends on what you are doing with your device. For me this ROM works fine for now (until a fixed Replicant ROM comes along), and I am never using any mobile phone for logging in on webpages, or carrying private data around, except for my contacts.

Thank you for looking into this!

I forgot to mention that I installed the ROM from SD-card. Before flashing the ROM, I cleared the system and dalvik/cache from within TWRP, then flashed the lineage rom, and after installation I cleared the dalvik/cache again. Rebooted, and then it worked.

Actions #22

Updated by Kurtis Hanna almost 5 years ago

Hello Niklas,

I'm curious, why did you choose to run LineageOS 14.1 instead of 15 or 16?


Actions #23

Updated by Jacob Bahn almost 5 years ago

Following the links from Kurtis Hanna I installed LineageOS 16.
There is no issue about the sound, i.e. the sound is good during calls.

I do have another issue though: It seems that OsmAnd can't catch any satellite and hence can't find the position
I also have some problems with the SIM card: Though it has been working for some time, the LineageOS now does not accept the pin code for the sim card.

I will try with an older version of LineageOS at some time

Actions #24

Updated by Jacob Bahn almost 5 years ago

After installing the LineageOS 14.1 which Niklas K uses, I got gps to work.
Sound will be tested later.

Actions #25

Updated by Kurtis Hanna over 4 years ago

  • Subject changed from Metalic and horrible sound quality when call are made through 3G network / Replicant 4.2 & 6.0 on I9300 to Metalic and horrible sound quality when call are made through 3G network / Replicant 4.2 & 6.0 on I9300 and N7100

If anyone would like to install LineageOS 14.1 for i9300 in order to compare logs as suggested in #1773#note-2, it seems like the most reliable place to get it is here:

Please note that you have to wait a bit after clicking the link to the Rom for two redirects to happen.

Actions #26

Updated by Denis 'GNUtoo' Carikli over 4 years ago

  • Target version changed from Any version to Replicant 6.0 0005
Actions #27

Updated by Denis 'GNUtoo' Carikli over 4 years ago

  • Device added
  • Device deleted (Galaxy S 3 (I9300))
Actions #28

Updated by Emmett Brown over 3 years ago


I just installed replicant 6.0004 RC4 on i9300, and i've got this problem of metallic sound when using 3G network.
It works weel with 2G network.
I don't know what todo
Is there any way to solved this issue ?


Actions #29

Updated by Denis 'GNUtoo' Carikli about 3 years ago

  • Type of work C programming added

It probably at least require libsamsung-ipc to detect the CODEC (GSM, AMR, etc) and sound parameters (8Khz, 16Khz) being in use.

Actions #30

Updated by Denis 'GNUtoo' Carikli about 3 years ago

We probably need to reproduce it to finally solve that issue.

Do you know on which networks it does it?

Can someone record the sound? For instance you could call your voicemail and connect an audio cable to your computer mic entry and record the sound.

Actions #31

Updated by Emmett Brown about 3 years ago


Please find attached two ogg files.
One record of a 2G phone call
One record of a 3G phone call
The volume is very low. Sorry. I use the app Call Recorder.

The only case when the 3G call works is when I call my voice mail.
Hope it will helps

Actions #32

Updated by tufek yamero about 3 years ago

Hi everyone,
I experienced the same issue on my S3 i9300 (I heard metallic voices on 3G phone calls, even when I called my own voicemail). Then I turned on 2G after reading this thread (it solved the issue btw thanks).
Now , when I set back to 3G the sound remains normal.

A big thank to all devs for all the work.

Actions #33

Updated by Nikos Parafestas almost 3 years ago


I had the horrible phone call sound problem when I used the S3 I9300. Sometimes it happened and sometimes not. I thought that it was as SIM slot problem until I used my partner's SIM and the sound problem disappeared (I have tested it only for an hour or so).

Then I changed device. I took the SIM I was using in my I9300 (the one I had the metallic sound) and have put it in a n7100. For about a month now, I am using a N7100 without any sound problem. I hope it helps.


Also available in: Atom PDF