Project

General

Profile

Issue #1778

The installation pages lack advice to backup the EFS partition

Added by Wolfgang Wiedmeyer about 3 years ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation instructions
Target version:
Start date:
05/08/2019
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Spent time:
(Total: 2.40 h)
Resolution:
Device:

Description

The installation pages of devices that have an EFS partition should advise to backup the EFS partition so users can restore the partition in case of corruption. This could prevent #1467 and would not require to install the proprietary stock images.

The page detailing the backup process should also include information about the necessary permissions the files should have to prevent network issues.


Subtasks

Issue #1930: Installation instructions: Add a section about backuping the EFSRejectedDenis 'GNUtoo' Carikli

Actions

Related issues

Related to Replicant - Issue #1467: i9300 lost IMEIClosed12/09/2015

Actions

History

#1

Updated by Wolfgang Wiedmeyer almost 3 years ago

#2

Updated by Denis 'GNUtoo' Carikli about 2 years ago

  • Category changed from 171 to Website and wiki content
#3

Updated by Denis 'GNUtoo' Carikli about 1 year ago

  • Category changed from Website and wiki content to Installation instructions
  • Target version changed from Any version to Replicant 6.0 0004
#4

Updated by Denis 'GNUtoo' Carikli about 1 year ago

This has been done (history in #1930) for most of the devices.

Only the following devices still need to be added:
  • Galaxy Note (N7000)
  • Galaxy Tab 2 7.0 (P3100)
  • Galaxy Tab 2 10.1 (P5100)
  • Galaxy Note 8.0 (N5100)
#6

Updated by Denis 'GNUtoo' Carikli about 1 year ago

  • Status changed from New to In Progress
#7

Updated by Kurtis Hanna 8 months ago

We now have two different wiki pages related to backing up the EFS partition:

https://redmine.replicant.us/projects/replicant/wiki/BackupTheEFS
https://redmine.replicant.us/projects/replicant/wiki/BackupsResearch

The Research based page seems to contain information that says that the other page needs to be updated because the commands at the other page stopped working and the backup were corrupted. If this is the case, we should update the BackupTheEFS page or ask that people test out the new commands on the Research page so we can determine if such a change should be made.

Additionally, we should add information related to best practices related to restoring one's EFS partition and link to it on the BackupTheEFS page.

#8

Updated by Denis 'GNUtoo' Carikli 8 months ago

  • The BackupTheEFS page is user instructions to backup the EFS.
  • The BackupsResearch is a documentation for the first page: It explains what worked and what didn't. Most users don't need that level of details, but people working on writing the user instructions do.
#9

Updated by Denis 'GNUtoo' Carikli 8 months ago

  • Status changed from In Progress to Resolved

The bug is fixed. The issue is

adb shell "cat /path/to/partition" > partition.img
, but
cat /path/to/partition > partition
is supposed to work.

To use adb pull directly on the partition we would need to validate that the '*' are working in such context.

Also available in: Atom PDF