Project

General

Profile

Issue #1781

Update Replicant USB Networking Page

Added by Anonymous about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Website and wiki content
Target version:
Start date:
03/15/2017
Due date:
% Done:

0%

Estimated time:
1.00 h
Resolution:
fixed
Device:

Description

I confirmed F-Droid 0.102.1 works with USB networking again. (I did have to enable my Cell network to upgrade from 0.102, however before re-enabling USB networking I restarted my phone and network configuration to make sure I wasn't accidently performing the "work around" solution that recommends downgrading to 0.101.

Also, you should add that on many phones 'adb root' needs to be run before executing any adb commands. Otherwise users will be greeted with the heart warming "Permission Denied" error.

Also also, I'd try clarifying the setting up connection on the PC step which asks you to change a network's IPv4 setting to "Shared to other computers". The simplest solution in my opinion is to make a short video or take a screenshot, however having step-by-step text for NetworkManager seems also appropriate. I.e.:

1. Click on NetworkManager icon/applet and press the "edit" button on the bottom of the menu
2. Examine your wired network connections the one talking to your phone. One of them (usually the highest numbered like "wired connection 3") should be trying to establish a DHCP connection over USB.
3. Highlight said connection and click the "Edit" button and then navigate to the "IPv4 Settings" tab.
4. Under the "Method" option change "Automatic (DHCP)" to "Shared to other computers". NetworkManager should now indicate a solid connection between the phone and your computer.
5. (Optional) Once you've confirmed the connection works by running the "start2" script command it might be wise to rename that wired connection to something obvious like "Replicant Helper". This can be done by changing the "Connection name" field at the top of the wired connection's "Edit" window

Hope no one else

History

#1

Updated by Anonymous about 3 years ago

Paul Hanzlik wrote:

I confirmed F-Droid 0.102.1 works with USB networking again. (I did have to enable my Cell network to upgrade from 0.102, however before re-enabling USB networking I restarted my phone and network configuration to make sure I wasn't accidently performing the "work around" solution that recommends downgrading to 0.101.

I messed up! Turns out that the only thing that doesn't work over USB networking in F-Droid is updating the repository itself, not downloading apps. Sorry if I mislead anyone, but hopefully downgrading again isn't too difficult.

#2

Updated by Wolfgang Wiedmeyer about 3 years ago

  • Status changed from New to In Progress

I copied the dev page to the actual networking page.

Paul Hanzlik wrote:

Also, you should add that on many phones 'adb root' needs to be run before executing any adb commands. Otherwise users will be greeted with the heart warming "Permission Denied" error.

This is mentioned at the beginning of the guide.

Also also, I'd try clarifying the setting up connection on the PC step which asks you to change a network's IPv4 setting to "Shared to other computers". The simplest solution in my opinion is to make a short video or take a screenshot, however having step-by-step text for NetworkManager seems also appropriate. I.e.:

1. Click on NetworkManager icon/applet and press the "edit" button on the bottom of the menu
2. Examine your wired network connections the one talking to your phone. One of them (usually the highest numbered like "wired connection 3") should be trying to establish a DHCP connection over USB.
3. Highlight said connection and click the "Edit" button and then navigate to the "IPv4 Settings" tab.
4. Under the "Method" option change "Automatic (DHCP)" to "Shared to other computers". NetworkManager should now indicate a solid connection between the phone and your computer.
5. (Optional) Once you've confirmed the connection works by running the "start2" script command it might be wise to rename that wired connection to something obvious like "Replicant Helper". This can be done by changing the "Connection name" field at the top of the wired connection's "Edit" window

I added a clarification where the connection name can be changed. Otherwise, I think the guide already covers these steps. Adding more details could cause more confusion because different network manager applets have quite varying interfaces. E.g. some of the details you are describing are not true for the nm-applet I'm using with the i3 window manager and I'm sure it looks different again in the KDE or Gnome Shell network applets.

Feel free to additionally create a video or screenshots and submit (or link to) these in this issue. Then we can discuss if or how the guide could be updated with them. But again, the screenshots or the video likely only apply to a certain network manager interface.

I messed up! Turns out that the only thing that doesn't work over USB networking in F-Droid is updating the repository itself, not downloading apps. Sorry if I mislead anyone, but hopefully downgrading again isn't too difficult.

This is an interesting detail. Feel free to mention this in the upstream bug.

#3

Updated by Wolfgang Wiedmeyer about 3 years ago

  • Status changed from In Progress to Feedback
  • Assignee changed from Wolfgang Wiedmeyer to Anonymous
  • Device added
  • Device deleted (Galaxy S 3 (I9300))
#4

Updated by Kurtis Hanna about 3 years ago

I mentioned the interesting detail in the upstream bug for Paul H, but I am tired and am not sure how clear I was about the fact that it seems like they seemed to have partially fixed the issue. Please feel free to clarify if deemed necessary. I noticed the same partial fix when using the external usb wifi dongle. Hopefully they finish fixing this up soon.

#5

Updated by Anonymous about 3 years ago

Thanks Wolfgang and Kurtis for such a fast response to this issue. (Makes me feel bad I'm responding a whole 14 days later haha.)

I realize now that gaining adb root access is mentioned on the webpage. However, I do think it would be worth mentioning more boldly by use of bold lettering, the specific command you need to run or a hyperlink to a Wiki page explaining how to gain adb root access and the perils of doing so. I also think there isn't much harm in including "If you see: "Permission Denied" please make sure you follow [hyperlink to instructions you glossed over]" under a "Troubleshooting" header of this page. In fact, I think adding a Troubleshooting section to the USB Networking page containing silly mistakes and their solutions would greatly improve this page.

I also agree now with Wolfgang that adding screenshots, videos or network manager specific instructions would probably be more trouble than it's worth. Perhaps a better way to smooth new Replicant users into USB networking would be to add a section on where to seek help configuring their laptops network manager. This section could include links to pertinent help documents for common network managers as well as clarify how to search and find help when things don't work. [That last request probably seems very "Let me Google that for you", but I do think making an effort instructing people how to find, report and solve problems pertinent to a Wikipage subject helps stimulate community involvement. Then again, I've never really been on the issue solver side of things . . .]

Hope all this makes sense, thanks for being so fast Wolfgang and sorry again for the late response!
Paul

#6

Updated by Wolfgang Wiedmeyer about 3 years ago

Paul Hanzlik wrote:

However, I do think it would be worth mentioning more boldly by use of bold lettering, the specific command you need to run or a hyperlink to a Wiki page explaining how to gain adb root access and the perils of doing so. I also think there isn't much harm in including "If you see: "Permission Denied" please make sure you follow [hyperlink to instructions you glossed over]" under a "Troubleshooting" header of this page. In fact, I think adding a Troubleshooting section to the USB Networking page containing silly mistakes and their solutions would greatly improve this page.

Added a hyperlink to the instructions. I think this should be sufficient. Adding mistakes to the troubleshooting section that cover errors which only happen when the guidelines are not followed properly seems redundant. Other wiki pages that cover similar instructions also don't have this. If this needs to be added, then it should be added to the ADB wiki page.

Perhaps a better way to smooth new Replicant users into USB networking would be to add a section on where to seek help configuring their laptops network manager. This section could include links to pertinent help documents for common network managers as well as clarify how to search and find help when things don't work. [That last request probably seems very "Let me Google that for you", but I do think making an effort instructing people how to find, report and solve problems pertinent to a Wikipage subject helps stimulate community involvement. Then again, I've never really been on the issue solver side of things . . .]

Feel free to make suggestions what specific content should go into this section. Please note that the target audience are users that have advanced knowledge and not beginners. The guide already requires to be familiar with the command line and being able to set up ADB according to the instructions. I expect that users with this level of experience to be able to find such information.

#7

Updated by Wolfgang Wiedmeyer about 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

Closing as I consider this fixed. If someone has issues with a certain network manager GUI, we can discuss this in the forums. Then we can go from there and decide how the wiki can be updated.

Also available in: Atom PDF