Project

General

Profile

Issue #1787

Issue #1861: Recommend to use an FSDG compliant distribution to build Replicant

Make Replicant 6.0 buildable on a GNU FSDG-compliant distribution

Added by Wolfgang Wiedmeyer over 2 years ago. Updated 7 days ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Category:
Freedom
Target version:
Start date:
04/09/2017
Due date:
% Done:

0%

Estimated time:
Resolution:
duplicate
Device:

Description

Replicant 6.0 makes use of many packaged build tools in Debian to avoid using prebuilt binaries shipped with the AOSP toolchain. These Android build tools packages are not yet available on any GNU FSDG-compliant distro, at least to my knowledge. Therefore, it is currently not possible to build the toolchain and Replicant images on such distros without significant changes to the build system.

The current release of Trisquel is too old to have these packages and it will likely take a long time until the needed packages become available in Trisquel. Parabola lacks these packages because these tools are not yet packaged for Arch-based distros.

This issue can be solved by asking Trisquel developers if it's possible to upload the packages to Trisquel's repos and make them available for the current or next release. For Parabola, the required steps need to be investigated, how the missing tools can be packaged.

As a temporary solution, we could provide an archive that contains all binaries that are either not available as part of packages on FSDG-compliant distros or that are not buildable on these distros. We could provide a script as part of the archive that puts the binaries in the right places in the source tree. Changes to the build system are necessary so that binaries from the archive are detected. This would make it possible to build Replicant images on FSDG-compliant distros with the limitation of using binaries from Debian and not having all the needed tools directly available as packages or buildable from source. It is still a far better solution than using the prebuilt AOSP tools.

The temporary solution should only be considered if it is in fact a lot more work to make the tools available in FSDG-compliant distros.


Related issues

Related to Replicant - Feature #837: Replicant Native Development Kit (NDK) build and releaseNew02/20/2014

Actions

History

#1

Updated by Wolfgang Wiedmeyer over 2 years ago

  • Subject changed from Make Replicant 6.0 buildable on a FSDG-compliant distribution to Make Replicant 6.0 buildable on a GNU FSDG-compliant distribution
  • Description updated (diff)
#2

Updated by Wolfgang Wiedmeyer over 2 years ago

See Toolchain for more information.

#3

Updated by Denis 'GNUtoo' Carikli over 1 year ago

  • Category changed from Build system to Freedom
#4

Updated by Denis 'GNUtoo' Carikli over 1 year ago

  • Has duplicate Issue #1861: Recommend to use an FSDG compliant distribution to build Replicant added
#5

Updated by Denis 'GNUtoo' Carikli over 1 year ago

  • Priority changed from High to Urgent
#6

Updated by Kurtis Hanna about 1 month ago

  • Status changed from New to Resolved
  • Resolution set to fixed

We can now build Replicant 6.0 in Trisquel so I'm closing this ticket.

#7

Updated by Kurtis Hanna about 1 month ago

  • Has duplicate deleted (Issue #1861: Recommend to use an FSDG compliant distribution to build Replicant)
#8

Updated by Kurtis Hanna about 1 month ago

  • Blocks Issue #1861: Recommend to use an FSDG compliant distribution to build Replicant added
#9

Updated by Kurtis Hanna about 1 month ago

  • Status changed from Resolved to In Progress
  • Resolution deleted (fixed)

I closed this ticket based on a misunderstanding. Denis had mentioned on our IRC channel that he built Replicant 9 on Trisquel, but this ticket is specifically about building Replicant 6 on Trisquel so it shouldn't have been closed.

It sounds like Trisquel 9 is ready to be tested, which potentially could make a Replicant 6.0 build easier to accomplish: https://trisquel.info/en/forum/trisquel-unstable#comment-143685

#10

Updated by Denis 'GNUtoo' Carikli 7 days ago

  • Parent task set to #1861
  • Resolution set to duplicate

This is a duplicate of #1861. #1861 has more informations so we can close this one.

#11

Updated by Denis 'GNUtoo' Carikli 7 days ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF