Project

General

Profile

Issue #1805

Ship a functional sshd_config

Added by Denis 'GNUtoo' Carikli over 2 years ago. Updated 8 months ago.

Status:
Rejected
Priority:
Normal
Category:
Website and wiki content
Target version:
Start date:
05/19/2017
Due date:
% Done:

0%

Estimated time:
Spent time:
Resolution:
Device:

Description

After generating the SSH keys with:

$ adb shell "/system/bin/ssh-keygen -A" 

Using the stock sshd_config with:

$ adb pull /etc/ssh/sshd_config
$ adb push sshd_config /data/ssh/sshd_config

results in:
$ adb shell "/system/bin/sshd" 
Could not load host key: /data/ssh/ssh_host_dsa_key

Commenting the following line in that configuration (and re-launching sshd):

HostKey /data/ssh/ssh_host_dsa_key

results in sshd starting fine.

History

#1

Updated by Denis 'GNUtoo' Carikli over 2 years ago

  • Category set to 171
  • Target version set to Replicant 6.0

Also update the tutorial (https://redmine.replicant.us/projects/replicant/wiki/SSH) when the issue is fixed.

#2

Updated by Wolfgang Wiedmeyer over 2 years ago

  • Assignee set to Wolfgang Wiedmeyer

Despite this error, ssh works fine. So the config is functional. I don't know why this error happens though. SSH runs as root and the key is there at /data/ssh/ssh_host_dsa_key.

#3

Updated by Denis 'GNUtoo' Carikli over 1 year ago

  • Category changed from 171 to Website and wiki content
#4

Updated by Denis 'GNUtoo' Carikli 9 months ago

  • Target version changed from Replicant 6.0 to Replicant 6.0 0004
#5

Updated by Denis 'GNUtoo' Carikli 8 months ago

  • Status changed from New to Rejected

It now works on Replicant 6.0 0003

Also available in: Atom PDF