Project

General

Profile

Issue #1810

Phone calls in WhisperSystem's Signal app fails

Added by Kurtis Hanna over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Graphics
Target version:
-
Start date:
06/14/2017
Due date:
% Done:

0%

Estimated time:
Resolution:
duplicate
Device:
Galaxy S 3 (I9300)

Description

Expected result:

Call screen opens, makes funky calling sound and shows text like "Calling" and "Establishing Signal call"

Actual result:

Signal stops, with message "Unfortunately, Signal has stopped" from the OS

Related posts / issues:

https://github.com/WhisperSystems/Signal-Android/issues/6583#issuecomment-308310744

https://redmine.replicant.us/boards/9/topics/14272

logs:

06-08 20:14:08.655 4189 4189 E AndroidRuntime: java.lang.RuntimeException: Unable to find any matching EGL config
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at org.webrtc.EglBase14.getEglConfig(EglBase14.java:236)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at org.webrtc.EglBase14.<init>(EglBase14.java:57)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at org.webrtc.EglBase.create(EglBase.java:86)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at org.webrtc.EglBase.create(EglBase.java:93)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at org.thoughtcrime.securesms.service.WebRtcCallService$7.run(WebRtcCallService.java:835)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at org.thoughtcrime.securesms.util.Util$2.run(Util.java:397)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at android.os.Handler.handleCallback(Handler.java:739)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at android.os.Handler.dispatchMessage(Handler.java:95)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at android.os.Looper.loop(Looper.java:148)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at android.app.ActivityThread.main(ActivityThread.java:5461)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at java.lang.reflect.Method.invoke(Native Method)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:726)
06-08 20:14:08.655 4189 4189 E AndroidRuntime: at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)

more logs: https://github.com/WhisperSystems/Signal-Android/files/1069493/signallog-crashedcall.453-submit.txt

History

#1

Updated by Wolfgang Wiedmeyer over 2 years ago

  • Status changed from New to Closed
  • Resolution set to duplicate

This is a duplicate of #705. However, it may work with llvmpipe, but it will probably be very slow.

Also available in: Atom PDF