Project

General

Profile

Issue #1811

missing Manifest.java when building Replicant 6 for i9300

Added by Fil Lupin almost 2 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
Build system
Target version:
Start date:
06/16/2017
Due date:
% Done:

0%

Resolution:
fixed
Device:

Description

When launching make, it fails because a Manifest.java is missing.
Any idea why?

============================================
PLATFORM_VERSION_CODENAME=REL
PLATFORM_VERSION=6.0.1
REPLICANT_VERSION="replicant-6.0" 
TARGET_PRODUCT=replicant_i9300
TARGET_BUILD_VARIANT=userdebug
TARGET_BUILD_TYPE=release
TARGET_BUILD_APPS=
TARGET_ARCH=arm
TARGET_ARCH_VARIANT=armv7-a-neon
TARGET_CPU_VARIANT=cortex-a9
TARGET_2ND_ARCH=
TARGET_2ND_ARCH_VARIANT=
TARGET_2ND_CPU_VARIANT=
HOST_ARCH=x86_64
HOST_OS=linux
HOST_OS_EXTRA=Linux-4.6.0-1-amd64-x86_64-with-debian-stretch-sid
HOST_BUILD_TYPE=release
BUILD_ID=MOB31T
OUT_DIR=/home/debian/replicant/replicant-6.0/out
WITH_SU=true
============================================
"ebtables is disabled on this build" 
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_errno.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_errno.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_interface.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_interface.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/SsbSipMfcApi.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/SsbSipMfcApi.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_errno.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_errno.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_interface.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_interface.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/SsbSipMfcApi.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/SsbSipMfcApi.h'
find: ‘dummy’: No such file or directory
build/core/base_rules.mk:559: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/root/res/images/charger/battery_fail.png'
build/core/base_rules.mk:559: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/root/res/images/charger/battery_fail.png'
PRODUCT_COPY_FILES device/samsung/smdk4412-common/rootdir/init.trace.rc:root/init.trace.rc ignored.
PRODUCT_COPY_FILES device/samsung/smdk4412-common/configs/audio_effects.conf:system/etc/audio_effects.conf ignored.
No private recovery resources for TARGET_DEVICE i9300
target Java: org.cyanogenmod.platform.sdk (/home/debian/replicant/replicant-6.0/out/target/common/obj/JAVA_LIBRARIES/org.cyanogenmod.platform.sdk_intermediates/classes)
javac: file not found: /home/debian/replicant/replicant-6.0/out/target/common/obj/APPS/org.cyanogenmod.platform-res_intermediates/src/cyanogenmod/platform/Manifest.java
Usage: javac <options> <source files>
use -help for a list of possible options
build/core/java.mk:394: recipe for target '/home/debian/replicant/replicant-6.0/out/target/common/obj/JAVA_LIBRARIES/org.cyanogenmod.platform.sdk_intermediates/classes-full-debug.jar' failed
make: *** [/home/debian/replicant/replicant-6.0/out/target/common/obj/JAVA_LIBRARIES/org.cyanogenmod.platform.sdk_intermediates/classes-full-debug.jar] Error 41

#### make failed to build some targets (02:43 (mm:ss)) ####

History

#1 Updated by Fil Lupin almost 2 years ago

Please replace the description upstairs by the following.

When launching make: it faild because a Manifest.java was missing.
Any idea why?

============================================
PLATFORM_VERSION_CODENAME=REL
PLATFORM_VERSION=6.0.1
REPLICANT_VERSION="replicant-6.0" 
TARGET_PRODUCT=replicant_i9300
TARGET_BUILD_VARIANT=userdebug
TARGET_BUILD_TYPE=release
TARGET_BUILD_APPS=
TARGET_ARCH=arm
TARGET_ARCH_VARIANT=armv7-a-neon
TARGET_CPU_VARIANT=cortex-a9
TARGET_2ND_ARCH=
TARGET_2ND_ARCH_VARIANT=
TARGET_2ND_CPU_VARIANT=
HOST_ARCH=x86_64
HOST_OS=linux
HOST_OS_EXTRA=Linux-4.6.0-1-amd64-x86_64-with-debian-stretch-sid
HOST_BUILD_TYPE=release
BUILD_ID=MOB31T
OUT_DIR=/home/debian/replicant/replicant-6.0/out
WITH_SU=true
============================================
"ebtables is disabled on this build" 
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_errno.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_errno.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_interface.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_interface.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/SsbSipMfcApi.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/SsbSipMfcApi.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_errno.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_errno.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_interface.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/mfc_interface.h'
build/core/copy_headers.mk:15: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/SsbSipMfcApi.h'
build/core/copy_headers.mk:15: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/obj/include/libsecmm/SsbSipMfcApi.h'
find: ‘dummy’: No such file or directory
build/core/base_rules.mk:559: warning: overriding recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/root/res/images/charger/battery_fail.png'
build/core/base_rules.mk:559: warning: ignoring old recipe for target '/home/debian/replicant/replicant-6.0/out/target/product/i9300/root/res/images/charger/battery_fail.png'
PRODUCT_COPY_FILES device/samsung/smdk4412-common/rootdir/init.trace.rc:root/init.trace.rc ignored.
PRODUCT_COPY_FILES device/samsung/smdk4412-common/configs/audio_effects.conf:system/etc/audio_effects.conf ignored.
No private recovery resources for TARGET_DEVICE i9300
target Java: org.cyanogenmod.platform.sdk (/home/debian/replicant/replicant-6.0/out/target/common/obj/JAVA_LIBRARIES/org.cyanogenmod.platform.sdk_intermediates/classes)
javac: file not found: /home/debian/replicant/replicant-6.0/out/target/common/obj/APPS/org.cyanogenmod.platform-res_intermediates/src/cyanogenmod/platform/Manifest.java
Usage: javac <options> <source files>
use -help for a list of possible options
build/core/java.mk:394: recipe for target '/home/debian/replicant/replicant-6.0/out/target/common/obj/JAVA_LIBRARIES/org.cyanogenmod.platform.sdk_intermediates/classes-full-debug.jar' failed
make: *** [/home/debian/replicant/replicant-6.0/out/target/common/obj/JAVA_LIBRARIES/org.cyanogenmod.platform.sdk_intermediates/classes-full-debug.jar] Error 41

#### make failed to build some targets (02:43 (mm:ss)) ####

#2 Updated by Wolfgang Wiedmeyer almost 2 years ago

  • Description updated (diff)
  • Assignee set to Wolfgang Wiedmeyer

You could try to run

mka org.cyanogenmod.platform-res

before running make bacon.

#3 Updated by Wolfgang Wiedmeyer almost 2 years ago

Did you only use one task, meaning make bacon instead of e.g. make -j4 bacon?

#4 Updated by Fil Lupin almost 2 years ago

Thank you for your answer.

I launched make without -j1 bacon so it was a mistake.
However, it fails again so I get back to first step (install build dependencies) and followed the different steps. I did not get again this missing file again.

This specific issue seems solved, I will open a new issue more pertinent with the error I got.
This issue can be closed.

#5 Updated by Wolfgang Wiedmeyer almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to fixed
  • Device deleted (Galaxy S 3 (I9300))

No need to open a new issue if this happens again. I added a BuildTips page where the issue is mentioned.

#6 Updated by Joonas Kylmälä 5 months ago

For me this problem came up because I ran 'make' instead of 'make bacon'.

Also available in: Atom PDF