Project

General

Profile

Actions

Issue #1867

closed

Download app not working when on USB network or RepWifi connection

Added by Fil Bergamo over 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
RepWifi
Target version:
Start date:
01/20/2018
Due date:
06/01/2018
% Done:

100%

Estimated time:
60.00 h
Resolution:
fixed
Device:
Grant:
Type of work:

Description

When no SIM is present, or mobile data are turned off, the Download app is pausing as soon as any download starts, and it never resumes.
This is almost certainly related to Issue #1792.

While #1792 was solved by patching the application framework, I suppose the Download app calls a different function in the framework and not the one that got patched. This could be a possible reason why the issue is not solved for it, while it is solved for other "regular" apps.

I will investigate and probably find a solution.


Related issues

Related to Replicant - Issue #1792: WiFi connection established via RepWifi not correctly reported by the Android Framework to user-space appsResolvedFil Bergamo04/12/201709/01/2017

Actions
Actions

Also available in: Atom PDF