Project

General

Profile

Issue #1953

Replicant 6.0 0003 Does Not Boot on I9250

Added by Anony Mous 9 months ago. Updated 8 months ago.

Status:
New
Priority:
High
Assignee:
-
Category:
Website and wiki content
Target version:
Start date:
09/04/2019
Due date:
% Done:

0%

Estimated time:
Resolution:
Device:
Galaxy Nexus (I9250)

Description

When booting up Replicant 6 on the Galaxy Nexus (I9250), it gets stuck on the Replicant splash screen. It never makes it to the actual OS. See https://redmine.replicant.us/boards/9/topics/15369

History

#1

Updated by Denis 'GNUtoo' Carikli 9 months ago

  • Category set to Website and wiki content

Can you manage to boot the recovery?

During the boot process, some partitions are mounted.

If the mounting of some partions fails for some reasons, that leads to symptoms similar to what you have.

So it might be a good idea to first try to boot to the recovery.

Then and if that works, it could be a good idea to try to mount the following partitions:
  • /dev/block/platform/omap/omap_hsmmc.0/by-name/system
  • /dev/block/platform/omap/omap_hsmmc.0/by-name/efs
  • /dev/block/platform/omap/omap_hsmmc.0/by-name/dgs
  • /dev/block/platform/omap/omap_hsmmc.0/by-name/cache
  • /dev/block/platform/omap/omap_hsmmc.0/by-name/userdata

If you already have adb setup in Replicant you might need to mount system in the recovery through the graphical user interface before getting access through adb.
If that fails you will need to find another recovery that has shell access by default. The Replicant 4.2 recovery should work for that.

If all partitions above can be mounted, then the problem might be something else.

It would be great to document in more detail this common issue in the wiki.

#2

Updated by Anony Mous 9 months ago

Ok, I flashed the Replicant 4.2 recovery to my phone, and booted into that. I opened up an adb shell on my computer, and tried to mount all of the partitions you listed. Here are the commands I ran, and their output:

~ # mount -o rw /dev/block/platform/omap/omap_hsmmc.0/by-name/system /system
~ # mount -o rw /dev/block/platform/omap/omap_hsmmc.0/by-name/efs /efs
mount: mounting /dev/block/platform/omap/omap_hsmmc.0/by-name/efs on /efs failed: No such file or directory
~ # mount -o rw /dev/block/platform/omap/omap_hsmmc.0/by-name/dgs /dgs
mount: mounting /dev/block/platform/omap/omap_hsmmc.0/by-name/dgs on /dgs failed: No such file or directory
~ # mount -o rw /dev/block/platform/omap/omap_hsmmc.0/by-name/cache /cache
mount: mounting /dev/block/platform/omap/omap_hsmmc.0/by-name/cache on /cache failed: Device or resource busy
~ # mount -o rw /dev/block/platform/omap/omap_hsmmc.0/by-name/userdata /userdata
mount: mounting /dev/block/platform/omap/omap_hsmmc.0/by-name/userdata on /userdata failed: No such file or directory

So either I did something wrong, or some of the partitions can't be mounted.

#3

Updated by Anony Mous 8 months ago

On the forums, a user named Gena Cheburashka found a method to make Replicant 6 boot on the Galaxy Nexus, by first installing Lineage OS 14.1. See this thread: https://redmine.replicant.us/boards/9/topics/15369?r=15414

This is good for a temporary workaround, but ideally Replicant 6 should be able to boot on its own, without having to install another operating system first. Hopefully this helps to narrow down the issue.

Also available in: Atom PDF