Project

General

Profile

Actions

Issue #1996

closed

Replicant 6.0 0004 RC1: Check that every device boot fine

Added by Denis 'GNUtoo' Carikli over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Start date:
01/29/2020
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed
Device:
Grant:
Type of work:
Actions #1

Updated by Denis 'GNUtoo' Carikli over 2 years ago

Status:

Device Boots to the desktop
Galaxy S 2 (I9100) OK
Galaxy S 3 (I9300) OK
Galaxy S 3 4G (I9305) OK
Galaxy Note (N7000) OK
Galaxy Note 2 (N7100) OK
Galaxy Nexus (I9250) boot fails: #1994
Galaxy Tab 2 7.0 (P3100) boot fails, with symptoms identical to the Galaxy Nexus (I9250)
Galaxy Tab 2 10.1 (P5100) No active developer has one, please help us testing it
Galaxy Tab 2 7.0 Wi-Fi (P3110) No active developer has one, please help us testing it
Galaxy Tab 2 10.1 Wi-Fi (P5110) No active developer has one, please help us testing it
Galaxy Note 8.0 (N5100) No active developer has one, please help us testing it
Galaxy Note 8.0 Wi-Fi (N5110) OK
Actions #2

Updated by green blue over 2 years ago

I don't know if it's ok for me to post here, but I can confirm hat the N5110 is booting Replicant 6.0 0004 rc1 correctly.

The graphics performance is ultra slow, 2 or 3 times slower than on the N7100 which has similar specs. It's borderline unusable, I think it should be mentioned somewhere. But that was already the case with 6.0 0003, so it is unrelated to 0004 (rc1).

Actions #3

Updated by Denis 'GNUtoo' Carikli over 2 years ago

Thanks a lot for the report.

Is the 2 or 3 times slower in portrait or landscape?

What happens when you switch orientation?

Actions #4

Updated by green blue over 2 years ago

I've only now tested this because the default is portrait - but the graphics seem to be much faster in landscape mode. In landscape mode, they're about equivalent to a N7100 in portrait mode, about 15-20 fps. In portrait mode, you only get 6-8 fps (rough estimate) on the N5110, while doing basic tasks, and it feels extremely sluggish. I personally prefer portrait mode on the N5110, for browsing and reading PDFs or eBooks.

Should we open another issue for this problem?

Actions #5

Updated by Kurtis Hanna over 2 years ago

David said on the replicant irc that, on Replicant 6, RGB555 is used throughout the entire stack.

Denis said we probably need RGB565 instead of RGB555 on Replicant 6 because neither omap nor exynos have the RGB555 DRM database format.

https://drmdb.emersion.fr/formats?driver=omapdrm
https://drmdb.emersion.fr/formats?driver=exynos

Denis then said that for Replicant 6 his recent patches probably unbroke booting on the Galaxy Nexus but broke booting on other devices.

Actions #6

Updated by Kurtis Hanna over 2 years ago

green blue wrote:

I've only now tested this because the default is portrait - but the graphics seem to be much faster in landscape mode. In landscape mode, they're about equivalent to a N7100 in portrait mode, about 15-20 fps. In portrait mode, you only get 6-8 fps (rough estimate) on the N5110, while doing basic tasks, and it feels extremely sluggish. I personally prefer portrait mode on the N5110, for browsing and reading PDFs or eBooks.

Should we open another issue for this problem?

Yes, please open another issue since this issue is simply about whether the devices boot or not.

Actions #7

Updated by Denis 'GNUtoo' Carikli almost 2 years ago

  • Status changed from New to Resolved
  • Assignee set to Denis 'GNUtoo' Carikli
  • Resolution set to fixed

That has been fixed in the RC2 already.

Actions

Also available in: Atom PDF