Project

General

Profile

Actions

Issue #2102

open

Replicant does not properly recognise a SIM card from a German internet provider

Added by A F almost 4 years ago. Updated about 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
SIM card not recognized
Target version:
Start date:
08/03/2020
Due date:
% Done:

0%

Estimated time:
40.00 h
Resolution:
Device:
Galaxy S 3 (I9300)
Grant:
Type of work:
Communication (mails, contacting people, etc), Unknown

Description

I've got the 삼성 Galaxy S3 i9300, and I installed Replicant 6.0004RC onto it. This OS did not even recognise my SIM card. I then installed Replicant 6.0003, which had no effect. Finally, I installed Replicant 4.2, and there at least it said "searching for networks", but the process went on forever until the battery charge was used up.

Here is some information I was asked in the forum to share here; it's about the contract:

  • Germany
  • Flat rate
  • Congstar, a subsidiary of "Deutsche Telekom"
  • The (northern hemisphere) summer of 2017 (start of contract, reception of the SIM card)
  • Only to be used for phone calls, not for internet surfing (the Corona app is the only reason I bought the smartphone)

I've also created a rather large log file, which seems to indicate an endless loop. A sample line from that log file is this:

getSimState: default sim:-1, sim state for slotIdx=0 is 6, return state as unknown

Please do indicate whether I ought to supply additional content from that log file.

Actions

Also available in: Atom PDF